Bug 1603611 - [3.10] Could not find an allocated subnet for node
Summary: [3.10] Could not find an allocated subnet for node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.z
Assignee: Avesh Agarwal
QA Contact: sheng.lao
URL:
Whiteboard:
: 1603612 1609056 (view as bug list)
Depends On: 1601378
Blocks: 1538616
TreeView+ depends on / blocked
 
Reported: 2018-07-19 18:01 UTC by N. Harrison Ripps
Modified: 2018-08-31 06:18 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Recently, cloudResourceSyncManager was implemented which continuously fetched node addresses from cloud providers. Kubelet then received node addresses from the cloudResourceSyncManager. At the time of node registration or kubelet start, kubelet fetches node addresses in a blocking loop from cloudResourceSyncManager. The issue was that cloudResourceSyncManager was not started before kubelet had started fetching node addresses from it for the first time, and due to this, kubelet got stuck in the blocking loop and never returned. It caused node failures at network level, and no node could be registered. Also as kubelet blocked early, the cloudResourceSyncManager never got a chance to start. Solution: CloudResourceSyncManager is now started early in the kubelet startup process so that kubelet does not get blocked on it and cloudResourceSyncManager is always started.
Clone Of: 1601378
Environment:
Last Closed: 2018-08-31 06:18:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2376 None None None 2018-08-31 06:18:51 UTC

Comment 1 N. Harrison Ripps 2018-07-19 18:04:24 UTC
*** Bug 1603612 has been marked as a duplicate of this bug. ***

Comment 2 Avesh Agarwal 2018-07-19 18:07:24 UTC
The PR is here: https://github.com/openshift/ose/pull/1364

Comment 3 Jan Chaloupka 2018-07-21 07:06:24 UTC
Fix merged in enterprise-3.10 branch: 
 https://github.com/openshift/ose/commit/0f1103b222705421380805acae4c56bb462e9b3f

Comment 5 Seth Jennings 2018-07-30 20:48:15 UTC
*** Bug 1609056 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2018-08-31 06:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2376


Note You need to log in before you can comment on or make changes to this bug.