Bug 160453 - terminal (ctrl-alt-f1,f2,etc) screens are blank once x starts
terminal (ctrl-alt-f1,f2,etc) screens are blank once x starts
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On: libvgahw
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 05:26 EDT by Flavio Cardone
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 13:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (50.79 KB, text/plain)
2005-06-16 05:17 EDT, Flavio Cardone
no flags Details
xorg.conf (3.56 KB, text/plain)
2005-06-16 05:18 EDT, Flavio Cardone
no flags Details
Xorg config file (2.76 KB, application/octet-stream)
2005-06-16 06:07 EDT, Iain Rae
no flags Details
Xorg log (39.21 KB, text/plain)
2005-06-16 06:09 EDT, Iain Rae
no flags Details
lspci -v (6.10 KB, text/plain)
2005-06-16 18:59 EDT, Norman Gaywood
no flags Details
file copied from FC3 working installation (20.43 KB, application/octet-stream)
2005-06-16 19:48 EDT, Jim Cornette
no flags Details
The attachement Today's Mess should show the processes encountered (65.75 KB, text/plain)
2005-06-16 19:52 EDT, Jim Cornette
no flags Details

  None (edit)
Description Flavio Cardone 2005-06-15 05:26:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Just installed FC4 over FC3. Booting in text mode shows, as usual, which modules are being started, etc. Once X starts and the login screen is shown, all terminal (ctrl-alt-f1 to f6) are blank and impossible to use. In fact, when rebooting or turning off the system and x is closed, the "shutting off" messages are not shown in the plain text screen, which stays blank.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start the system
2. start x
3. press ctrl-alt-f1
  

Actual Results:  screen is blank

Expected Results:  a tty terminal should be shown

Additional info:
Comment 1 daleville 2005-06-15 08:36:16 EDT
Same thing here. Starting Fedora at Run Level 3 will display the text login as
expected and allow login, however after starting X and then attempting to logout
and return to terminal prompt nothing but a blank screen is displayed. It is
still possible to type commands, you just have no idea what's going on. For
example I logged off Gnome, couldn't see anything on the screen, typed startx
again and Gnome loaded back up.
Comment 2 Jim Cornette 2005-06-15 20:16:23 EDT
I have seen the blank screen on an Intel 865G. I also saw a different behavior
of a blue border with visible text using an Intel 815 video card. Same driver,
different card.
This seems related to the same cause that messes up the MGA card in a lot worse
ways than the Intel.

Adding your video card type, xorg.conf file, xorg.0.log file might help the
developers track down the problem.

Comment above describes runlevel 3 well. runlevel 5 has blank terminals also.
Comment 3 Flavio Cardone 2005-06-16 05:17:20 EDT
Created attachment 115526 [details]
Xorg.0.log
Comment 4 Flavio Cardone 2005-06-16 05:18:43 EDT
Created attachment 115527 [details]
xorg.conf
Comment 5 Iain Rae 2005-06-16 06:05:18 EDT
I have an ATI mach64 3d Rage IIC with the ati driver and I'm seeing something
slightly different. When you switch to a virtual console the screen is left with
whatever was on the X display; hitting return eventually results in the screen
sliding to the left on each return.
Comment 6 Iain Rae 2005-06-16 06:07:24 EDT
Created attachment 115533 [details]
Xorg config file
Comment 7 Iain Rae 2005-06-16 06:09:12 EDT
Created attachment 115534 [details]
Xorg log
Comment 8 Imre Gergely 2005-06-16 07:49:21 EDT
i have an ibm thinkpad R50e, with
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)

the same thing happens. with FC2 there was no problem. i upgraded to FC4, now as
soon as i start X, the text mode is gone. i noticed something else too. if i run
startx, two more modules are loaded:
[root@Laptop ~]# lsmod
i915                   19009  1 
drm                    70101  2 i915
...

when i exit from X, of course i don't see anything on the console, so i logged
in through the network, and tried to unload those modules:

[root@Laptop ~]# lsmod
Module                  Size  Used by
i915                   19009  0 
drm                    70101  1 i915
...

[root@Laptop ~]# rmmod i915
[root@Laptop ~]# rmmod drm
Segmentation fault
[root@Laptop ~]# 
[root@Laptop ~]# rmmod drm
ERROR: Removing 'drm': Device or resource busy
[root@Laptop ~]# 

xorg.conf is the one coming with FC4, i did not alter it in any way.
Comment 9 daleville 2005-06-16 08:04:37 EDT
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 03)

Section "Device"
    Identifier  "Videocard0"
    Driver      "i810"
    VendorName  "Videocard vendor"
    BoardName   "Intel 845"
    BusID       "PCI:0:2:0"
EndSection
Comment 10 Norman Gaywood 2005-06-16 18:57:18 EDT
I have the same problem with an Intel i915 display chip. I thought it might have
been the fact that I compiled the latest http://dri.freedesktop.org/snapshots/
to get my card working. However it appears others have a similar problem.

I noticed this in /var/log/messages:

kernel: mtrr: base(0xc0020000) is not aligned on a size(0x834000) boundary

Will attach lspci -v
Comment 11 Norman Gaywood 2005-06-16 18:59:41 EDT
Created attachment 115583 [details]
lspci -v

Includes details of i915
Comment 12 K. Richard Pixley 2005-06-16 19:17:59 EDT
Similar problems with a matrox card.  I see virtual terminals with neon green
frames, but no content, no text, no getty.
Comment 13 Jim Cornette 2005-06-16 19:40:29 EDT
I replaced /usr/X11R6/lib/modules/libvgahw.a
with the file from an FC3 intallation on the same computer and replaced the
version included in the xorg-x11-6.8.2-37
 I renamed the file to libvgahw.a.fromfc3 so I could include it in this report
as an atachment.

Anyway, my terminals are back after I replaced the file and rebooted the
computer. I will attach my message log for today's entries for any useful
messages regarding the messed up VT.

I do not get the blue border or any wrappingtext with the replacement of the file.
Comment 14 Jim Cornette 2005-06-16 19:48:51 EDT
Created attachment 115586 [details]
file copied from FC3 working installation

The owner of the file should be root:root
The name and location should be
/usr/X11R6/lib/modules/libvgahw.a

you must reboot your computer for the changes to take effect.

Hopefully the messages will show some useful output. Next attachment. Before
and after replacing the file and rebooting.
Comment 15 Jim Cornette 2005-06-16 19:52:47 EDT
Created attachment 115587 [details]
The attachement Today's Mess should show the processes encountered

Hopefully the messages are helpful.
I grepped with 16, so hopefully all of todays entries are included.
Comment 16 K. Richard Pixley 2005-06-16 19:57:05 EDT
Reverting /usr/X11R6/lib/modules/libvgahw.a works for me & my matrox too.

I don't understand why changing a static library would have that affect. 
*shrug*.  But perhaps this will all help someone narrow in on whatever problem
was recently introduced.
Comment 17 Jim Cornette 2005-06-16 20:11:21 EDT
I have to try with the Intel 865G tomorrow to see if the blank terminal is cured
also.
The graphics in the GUI are excellent. The blank terminals are in the VT, which
confuses my as to why the VT is corrupted and Screen 7 works great still.
Comment 18 Jim Cornette 2005-06-16 20:28:29 EDT
Browsing through the messages that I submitted today, I found this entry within
the log. I expected at least two entries, since I reboot the computer.

Jun 16 19:21:20 cornette-fc4t3 kernel: Console: colour VGA+ 80x25

I rebooted the machine, so I expected at least another entry.
With the grep 16 I caught the previous entry from an earlier date.

I get this output from a radeon which I don't see any abnormalities on the machine.

 cat /var/log/messages |grep VGA
Jun 13 06:34:33 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 13 06:34:36 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 13 15:42:38 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 13 15:42:41 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 14 06:23:42 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 14 06:23:45 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 14 15:52:33 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 14 15:52:36 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 14 22:34:05 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 14 22:34:08 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 15 06:35:38 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 15 06:35:41 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 15 17:09:49 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 15 17:09:52 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 16 06:25:29 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 16 06:25:32 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Jun 16 17:04:02 cornette-lt kernel: Console: colour VGA+ 80x25
Jun 16 17:04:06 cornette-lt kernel: ACPI: Video Device [VGA] (multi-head: yes  r
om: no  post: no)
Comment 19 Scott Carper 2005-06-17 00:06:05 EDT
I tried the libvgahw.a work-around on my 865G system and it works fine-VT's are
back!
Comment 20 Michael A. Peters 2005-06-17 00:26:34 EDT
I wonder what happens if that file is compiled with gcc32 instead of gcc4.
I don't know if that's the reason, but that is a difference between FC3 and FC4
(and yes, there are other differences as well - such as a different version of xorg)
Comment 21 John Villalovos 2005-06-17 01:48:29 EDT
I am also seeing this problem on my system which uses an Intel i810 video chipset.

00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 01)
Comment 22 Flavio Cardone 2005-06-17 03:27:22 EDT
.. and my terminals are back too :-)
Comment 23 Imre Gergely 2005-06-17 04:58:04 EDT
mine too, but now after two or three switches to text and back, i can't  do
anything in WindowMaker. the menu won't appear, the window decorations all gone,
and i can't open another window. i have to restart X (with Ctrl+Alt+Backspace).
Comment 24 Tornoczky Zoltan 2005-06-19 03:48:17 EDT
I changed the file, but it made no effect
Comment 25 Jim Cornette 2005-06-19 08:27:23 EDT
What card type do you have? Did you reboot to see if the file replacement
prevented blanking terminals?

Reference to the upstream bug report is below.
https://bugs.freedesktop.org/show_bug.cgi?id=2991
Comment 26 Alar Suija 2005-06-19 08:35:24 EDT
Same here, in two machines, one with Matrox G200 and old IBM Thinkpad 600
(NeoMagic MagicGraph 128XD)
For me, workaround was simply disabling rhgb. After that at least T600 works
O.K. now (no test w. G200 yet).
Comment 27 John Villalovos 2005-06-20 02:12:01 EDT
I tried removing "rhgb" in GRUB.  This made NO difference for me.  I still can
NOT see text after exiting from X Windows.
Comment 28 Alar Suija 2005-06-20 03:42:19 EDT
Removing rhgb not works for box w. matrox G200 but 100% for T600. But there is
diference after disabling rhgb, before screen simply hangs after switch (to
virtual terminal), now i see blank screen with green border.

Both machines have xorg-x11-6.8.2-37
Comment 29 Alar Suija 2005-06-20 09:18:29 EDT
Changed video card, Ati Rage 128 Pro GL PF works O.K. with rhgb disabled, no VT
when using rhgb.
Comment 30 Mike A. Harris 2005-06-21 13:48:34 EDT
(In reply to comment #16)
> Reverting /usr/X11R6/lib/modules/libvgahw.a works for me & my matrox too.
> 
> I don't understand why changing a static library would have that affect. 
> *shrug*.  But perhaps this will all help someone narrow in on whatever problem
> was recently introduced.

It is a dynamiclly loaded X server module, not a static library.  The X
server modules can be .a, .o, or .so objects.

We're tracking the underlying problem in bug #161242 if anyone is interested
in CC'ing themselves.

Thanks for testing this out, and providing the feedback, as it has shown
that whatever the root problem is here, that it is affecting a lot more
people than originally anticipated, and seems to be the cause of numerous
bugs on various different hardware.

Comment 31 Mike A. Harris 2005-06-21 14:02:39 EDT
Adding to libvgahw tracker bug #161242.
Comment 32 Mike A. Harris 2005-06-23 13:54:08 EDT

*** This bug has been marked as a duplicate of 161242 ***
Comment 33 B. L. Massingill 2005-07-28 17:03:56 EDT
Same symptoms with Intel 865G; libvgahw.a workaround works for me too.
Comment 34 Jose Filipe 2005-07-29 06:31:59 EDT
Thank you very muth !!! :-))

I've a Dell computer with intel 865 video card.
And i've been very  anxious with the black screens on reboot, CTRL+ALT+Fx (x =
1,2,3, ...)
I've replaced /usr/X11R6/lib/modules/libvgahw.a with the somme in FC3
installation, and this works and bye black screens !!

I'm very happy !! :-))


(In reply to comment #14)
> Created an attachment (id=115586) [edit]
> file copied from FC3 working installation
> 
> The owner of the file should be root:root
> The name and location should be
>  anxious
> 
> you must reboot your computer for the changes to take effect.
> 
> Hopefully the messages will show some useful output. Next attachment. Before
> and after replacing the file and rebooting.


Note You need to log in before you can comment on or make changes to this bug.