Bug 160455 - _SERIOUS_ problem in eclipse
_SERIOUS_ problem in eclipse
Status: CLOSED DUPLICATE of bug 152386
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 05:38 EDT by Andrea Santilli
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-15 08:41:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2005-06-15 05:38:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Running Eclipse as root completely hangs the system (1 x Pentium4 HT 2600MHz, maybe it's because of the smp).
When I run it again (as root, after forced reboot) I get an error message saying to see details in a log file. On that log file there's written as follows:

!SESSION 2005-06-15 10:21:08.681 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=GNU libgcj 4.0.0 20050519 (Red Hat 4.0.0-8)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=it_IT
Command-line arguments:  -os linux -ws gtk -arch x86 -data /root/workspace -clean

!ENTRY org.eclipse.osgi 2005-06-15 10:21:08.682
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run(java.lang.Object) (/usr/lib/eclipse/plugins/org.eclipse.core.runtime_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.Object) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.6.0.0)
   at org.eclipse.core.launcher.Main.invokeFramework(java.lang.String[], java.net.URL[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.basicRun(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

If I can't run it as root, it's supposed I must install a copy of new plugins for every user...

Running it as normal user (after doing all I've written before) I get the same error.

I had to uninstall eclipse and all its depedancies, erase /usr/share/eclipse dir and install it again. Now it runs good (only as normal user).

Version-Release number of selected component (if applicable):
3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Run eclipse as root. The system completely hangs.
2. Restart eclipse after forced reboot
3. I get that error
  

Actual Results:  System hang, wrong configuration.

Expected Results:  Eclipse run perfectly

Additional info:

Running on a SMP kernel (1 x Pentium 4 HyperThreading 2600MHz)
Comment 1 stef 2005-06-15 05:52:52 EDT
I confirm, crashes the whole system if run as root.
System is a PIII 1GHz mono-cpu with 256Mo RAM and SCSI160 disk, so seems not SMP
related.
Comment 2 Andrew Overholt 2005-06-15 08:41:34 EDT

*** This bug has been marked as a duplicate of 152386 ***

Note You need to log in before you can comment on or make changes to this bug.