Bug 160477 - When X starts the graphics get messed up
When X starts the graphics get messed up
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 08:35 EDT by Kaare Teilum
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 17:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaare Teilum 2005-06-15 08:35:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When the computer boot there are no problems with the graphics. The GRUB screen appears OK and the first lines of messages during linux-startup is also OK. Just when the FC graphic boot screen appears the graphics get messed up - and the graphics stay messed up no matter what i do. I was also unable to use the graphic installation as I had the same problems.
My graphic adaptor is a Matrox Millenium G550, the processor Athlon XP 3200+, and the motherboard an Asus A7N8X.
I have run installations of both FC1 and FC2 on this machine without any problems.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31

How reproducible:
Always

Steps to Reproduce:
1.Boot the machine
2.
3.
  

Additional info:
Comment 1 Mike A. Harris 2005-06-21 13:02:38 EDT
Does bug #153729 adequately describe the problem?

Please attach your X server config file and log file.
Comment 2 Mike A. Harris 2005-06-21 13:41:46 EDT
Also, have a look at bug #161242 which is a new master bug I've made to
track the problem which I think might be the root cause of the issue
reported here and elsewhere in bugzilla.

Thanks in advance.
Comment 3 Mike A. Harris 2005-06-23 13:47:25 EDT
For those experiencing issues of this nature, I have uploaded the libvgahw.a
X server module from the current FC3 errata release to my ftp space:

ftp://people.redhat.com/mharris/libvgahw.a

This should make it easier for some people to test out the module hopefully,
and also have a temporary workaround.

Please provide feedback on the results of your testing ASAP.

Setting status to "NEEDINFO"
Comment 4 Kaare Teilum 2005-06-28 06:06:43 EDT
I did have an intense green border and otherwise pale green terminals in
ctrl/alt/1-6 and replaceing libvgahw with the FC3 version removed the green
stuff but the text was still unreadable. The same appearance as in the graphic
mode (ctrl/alt/7) was observed - namely that the display is divided in 1 cm
vertical sections and that some of these sections are copies of the section next
to the neighbouring section (do you get what I mean??)

Notice that the problem appeared already under graphical installation. I had to
use text installation which showed none of the problems.

As I was only able to work on the computer by ssh access from another computer I
tried to downgrade X to xorg-x11-6.8.2-1.FC3.13 which solved all problems. I did
not make a copy of the X server config and log files and don't have the time
right now to upgrade X to the FC4 version to get that done.

I think there are two issues both the green border thing and something else -
just like in bug 153729.
Comment 5 Mike A. Harris 2005-06-29 17:19:20 EDT

*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.