Bug 1604884 - mosh: FTBFS in Fedora rawhide
Summary: mosh: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mosh
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex Chernyakhovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1551327 F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 00:58 UTC by Mohan Boddu
Modified: 2019-09-22 15:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-22 15:01:57 UTC
Type: ---


Attachments (Terms of Use)
build.log (11.34 KB, text/plain)
2018-07-20 00:58 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 00:58 UTC, Mohan Boddu
no flags Details
state.log (607 bytes, text/plain)
2018-07-20 00:58 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 00:58:09 UTC
mosh failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28202802


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix mosh at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
mosh will be orphaned. Before branching of Fedora 30,
mosh will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 00:58:17 UTC
Created attachment 1464448 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 00:58:24 UTC
Created attachment 1464449 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 00:58:27 UTC
Created attachment 1464450 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 09:22:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Penelope Fudd 2019-06-03 04:02:22 UTC
I tried to run mosh-1.3.0-1.el7.x86_64.rpm but I kept getting this error:
mosh-server: symbol lookup error: mosh-server: undefined symbol: _ZNK6google8protobuf11MessageLite25InitializationErrorStringEv
Connection to 11.11.22.33 closed.
/usr/bin/mosh: Did not find mosh server startup message. (Have you installed mosh on your server?)

Signature   : RSA/SHA256, Sun 26 Mar 2017 02:28:23 PM PDT, Key ID 6a2faea2352c64e5
Source RPM  : mosh-1.3.0-1.el7.src.rpm
Build Date  : Sun 26 Mar 2017 02:25:46 PM PDT
Build Host  : buildhw-10.phx2.fedoraproject.org

I downloaded the source package and tried to build it, and it failed in the configuration step, with 'cpp failed sanity check'.

By installing gcc-g++, (yum install -y gcc-c++), I was able to rebuild the package and get mosh running.

The mosh spec file needs to specify a build dependency on gcc-g++, I think.

Cheers!


Note You need to log in before you can comment on or make changes to this bug.