Bug 160502 - ssh: error while loading shared libraries: libkrb5.so.3
ssh: error while loading shared libraries: libkrb5.so.3
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssh (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 10:47 EDT by Julie Battle
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-04 03:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julie Battle 2005-06-15 10:47:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Just did a fresh install of version 3, update 5.  Tried to use ssh to connect to other machines:

got this error:

ssh: error while loading shared libraries: libkrb5.so.3
cannot open shared object file: No such file or directory

I modified my PATH environment variable to point to /usr/kerberos/[lib|lib64]/libkrb5.so.3, but still couldn't ssh.

Had Update 5 BETA previously loaded on this exact architecture, and ssh worked fine there.

Searched RedHat Knowledgebase for "libkrb5.so.3" and just got a bunch of nonsense that has nothing to do with libkrb5.so.3.

Help !

Julie Battle
724-275-5029

Version-Release number of selected component (if applicable):
Version 3 Update 5

How reproducible:
Always

Steps to Reproduce:
1. type ssh on the command line
2. watch error appear
3.
  

Actual Results:  received error, then got a prompt back

Expected Results:  I should have gotten a secure-shell connection to another server.  Network connectivity exists, because telnet outbound works OK.

Additional info:
Comment 1 Tomas Mraz 2005-06-15 11:07:58 EDT
What is the contents of the /etc/ld.so.conf file?
Comment 2 Tomas Mraz 2005-07-01 04:26:50 EDT
And what ldd /usr/bin/ssh prints?
Comment 3 Tomas Mraz 2005-07-04 03:48:41 EDT
I've got a mail from the reporter that this bug no longer happens on her system
after reinstalling.

Note You need to log in before you can comment on or make changes to this bug.