Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1605025

Summary: "Monitor Event Queue" and "Listen on candlepin events" may enter paused state after restarting foreman-tasks
Product: Red Hat Satellite Reporter: Hao Chang Yu <hyu>
Component: Tasks PluginAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.3.2CC: aruzicka, hyu, inecas, jangerrit.kootstra
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-23 12:44:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Hao Chang Yu 2018-07-20 03:20:38 UTC
Description of problem:
If user restart foremn-tasks process when "Monitor Event Queue" or "Listen on candlepin events" task is running a job. The task will fail with "abnormal termination" and the foreman task will enter paused state after restarting. No new "Monitor Event Queue" or "Listen on candlepin events" tasks are created after the failure. User needs to restart foreman-tasks again to bring this task back.

Without the "Listen on candlepin events", the katello_event_queue will slowly flood with messages.

It looks like there is also a bug in the Candlepin version that Satellite is using.
https://bugzilla.redhat.com/show_bug.cgi?id=1579387

When the queue is in flow_stopped, Candlepin will create a new connection to Qpid. This will slowly reach the max of 500 qpid connections. Qpid started to reject connections and cause other components such as Dynflow and Pulp to fail.

How reproducible:
1) Push some import applicability tasks jobs to Katello::Event (To make this easier to reproduce, I add a 2 minutes sleep in the import applicability method)
2) Wait for awhile so that Katello::Event will pick up the task
3) systemctl restart foreman-tasks
4) Wait for awhile to let dynflow to invalidate the tasks of the old world. Go to the Satellite web ui tasks monitor page, and I saw "Monitor Event Queue" is in paused state.

Comment 3 Adam Ruzicka 2018-07-23 12:33:32 UTC
What versions of katello, foreman-tasks and dynflow does the customer have?

Comment 4 Adam Ruzicka 2018-07-23 12:44:46 UTC
Nvm, found the version numbers.

This is most likely a duplicate of BZ1476796. If you feel that BZ doesn't fully cover this one, please feel free to reopen this one.

*** This bug has been marked as a duplicate of bug 1476796 ***