Bug 1605048 (CVE-2018-1333) - CVE-2018-1333 httpd: mod_http2: Too much time allocated to workers, possibly leading to DoS
Summary: CVE-2018-1333 httpd: mod_http2: Too much time allocated to workers, possibly ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-1333
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20180718,repor...
Depends On: 1605049 1605050 1609083 1616051
Blocks: 1605053
TreeView+ depends on / blocked
 
Reported: 2018-07-20 04:49 UTC by Sam Fowler
Modified: 2019-06-14 08:56 UTC (History)
59 users (show)

Fixed In Version: httpd 2.4.34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:33:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3558 None None None 2018-11-13 08:36:49 UTC
Red Hat Product Errata RHSA-2019:0366 None None None 2019-02-18 16:55:53 UTC
Red Hat Product Errata RHSA-2019:0367 None None None 2019-02-18 16:58:35 UTC

Description Sam Fowler 2018-07-20 04:49:23 UTC
Apache httpd before version 2.4.34 has a vulnerability in the handling of specially crafted HTTP/2 requests, causing workers to be allocated 60 seconds longer than necessary, leading to worker exhaustion and a denial of service.

This issue only affects servers that have configured and enabled HTTP/2 support, which is not the default


External References:

https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2018-1333

Comment 1 Sam Fowler 2018-07-20 04:50:06 UTC
Created httpd tracking bugs for this issue:

Affects: fedora-all [bug 1605049]

Comment 3 Tomas Hoger 2018-07-20 07:14:27 UTC
HTTP/2 support was first added upstream in version 2.4.17:

https://httpd.apache.org/docs/2.4/mod/mod_http2.html
http://archive.apache.org/dist/httpd/CHANGES_2.4.17

Hence earlier versions can not be affected.  Additionally, upstream lists version 2.4.18 as the first affected.

Comment 9 Scott Gayou 2018-08-14 19:39:35 UTC
httpd24-httpd (2.4.27) appears to be vulnerable. http2 modules are built and loaded by default.

Comment 12 errata-xmlrpc 2018-11-13 08:36:31 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 6
  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.4 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.5 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.6 EUS

Via RHSA-2018:3558 https://access.redhat.com/errata/RHSA-2018:3558

Comment 15 errata-xmlrpc 2019-02-18 16:55:52 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Core Services

Via RHSA-2019:0366 https://access.redhat.com/errata/RHSA-2019:0366

Comment 16 errata-xmlrpc 2019-02-18 16:58:32 UTC
This issue has been addressed in the following products:

  JBoss Core Services on RHEL 6
  JBoss Core Services on RHEL 7

Via RHSA-2019:0367 https://access.redhat.com/errata/RHSA-2019:0367


Note You need to log in before you can comment on or make changes to this bug.