Bug 160519 - Installer uses VESA Generic driver and fails to output a GUI
Installer uses VESA Generic driver and fails to output a GUI
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 11:36 EDT by Jan Owoc
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 04:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Owoc 2005-06-15 11:36:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
When I boot FC4 graphical install from DVD (mediacheck is PASS), the installer detects a VESA Generic card, but the graphical installer fails to display any output on the monitor.
Text-based install works, but on first boot there is the same "no output" problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from the FC4 DVD.
2. Select graphical install.

  

Actual Results:  The graphical interface gives "no signal" to the monitor.

Expected Results:  A gui-based screen with "Welcome to Fedora Core 4" should have appeared.

Additional info:

My computer is an Intel Pentium 4 with a Matrox P650 video card.

This problem has been reproduced with similar results on:
- Matrox G550 - architecture unknown
- Integrated Intel video - Dell Poweredge sc420 server
- Matrox Parhelia 128MB - Athlon MP

In all four cases, the LCD monitor was properly detected.
Comment 1 Mike A. Harris 2005-06-22 17:24:19 EDT
Please review "bug #161242" everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.


Comment 2 Wayne Carruthers 2005-07-12 23:59:34 EDT
Can also confirm where FC3 worked beautifully on a genuine Intel BX440 dual PII
motherboard with Cirrus Logic GD5480 onboard video at up to 1024x768 res

FC4 simply gives horozontal line onscreen regardless of what monitor is connected

Attempts to use a variety of other old S3 Verge & Trident Video cards gave
patchy results with odd characters onscreen during boot and at times either
white or blue blank video screen. At times even unable to change to another
terminal to text mode to look at xorg.conf. 

Where I was able to look at xorg.conf the correct video card was set

Eventually increased memory on an old S3 Verge & now able to run X without
spurious characters

Attempts to debug cause confusing to say the least
Comment 3 Simon Rycroft 2005-08-01 05:52:17 EDT
I can add that the exact same symptoms are displayed on install (using YUM) of
the current FC3 development versions of Xorg (yum update xorg*).  I am using a
P650 here which failed to install FC4, so am aware that the problem is identical
to the one above.
Comment 4 Mike A. Harris 2005-08-30 04:10:34 EDT

*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.