Bug 1605403 - perl-CryptX FTBFS: tests fail with libtomcrypt-1.18.2
Summary: perl-CryptX FTBFS: tests fail with libtomcrypt-1.18.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-CryptX
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 15:14 UTC by Mohan Boddu
Modified: 2018-12-14 20:41 UTC (History)
2 users (show)

Fixed In Version: perl-CryptX-0.053-7.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 17:04:09 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2018-07-20 15:14 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 15:14 UTC, Mohan Boddu
no flags Details
state.log (635 bytes, text/plain)
2018-07-20 15:14 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 15:14:24 UTC
perl-CryptX failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28211719


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix perl-CryptX at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
perl-CryptX will be orphaned. Before branching of Fedora 30,
perl-CryptX will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 15:14:31 UTC
Created attachment 1465392 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 15:14:36 UTC
Created attachment 1465393 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 15:14:39 UTC
Created attachment 1465394 [details]
state.log

Comment 4 Petr Pisar 2018-07-23 06:30:21 UTC
This is caused by upgrading libtomcrypt-devel from 1.18.1-5.fc29 to 1.18.2-1.fc29.

Comment 5 Jan Kurik 2018-08-14 11:03:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 6 Fedora Update System 2018-11-29 14:47:39 UTC
perl-CryptX-0.053-7.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e395d42595

Comment 7 Fedora Update System 2018-11-30 15:12:33 UTC
perl-CryptX-0.053-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e395d42595

Comment 8 Randy Barlow 2018-12-11 17:04:09 UTC
A Fedora update associated with this bug has been pushed to the stable repository.

Comment 9 Randy Barlow 2018-12-14 20:41:19 UTC
A Fedora update associated with this bug has been pushed to the stable repository.


Note You need to log in before you can comment on or make changes to this bug.