Bug 1605613 - python-beaker: FTBFS in Fedora rawhide
Summary: python-beaker: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-beaker
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1578323 (view as bug list)
Depends On:
Blocks: F29FTBFS PYTHON37 1585626
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:14 UTC by Mohan Boddu
Modified: 2018-08-01 00:36 UTC (History)
3 users (show)

Fixed In Version: python-beaker-1.10.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-01 00:36:25 UTC


Attachments (Terms of Use)
build.log (4.43 KB, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details
state.log (647 bytes, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 16:14:58 UTC
python-beaker failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28220628


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-beaker at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-beaker will be orphaned. Before branching of Fedora 30,
python-beaker will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:15:06 UTC
Created attachment 1466004 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 16:15:10 UTC
Created attachment 1466005 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:15:13 UTC
Created attachment 1466006 [details]
state.log

Comment 4 Miro Hrončok 2018-07-23 13:54:33 UTC
*** Bug 1578323 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2018-07-25 09:26:04 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 6 Miro Hrončok 2018-07-31 19:32:24 UTC
Note that trying to upgrade a fresh Fedora 28 Workstation to Fedora 29, this package block the upgrade. I don't have enough disk space to try dnf update first.


Note You need to log in before you can comment on or make changes to this bug.