Bug 1605614 - python-behave: FTBFS in Fedora rawhide
Summary: python-behave: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-behave
Version: 29
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FTBFS F29BetaFreezeException PYTHON37 1585626
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:15 UTC by Mohan Boddu
Modified: 2018-09-05 01:08 UTC (History)
4 users (show)

Fixed In Version: python-behave-1.2.6-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-05 01:08:59 UTC


Attachments (Terms of Use)
build.log (8.62 KB, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details
state.log (647 bytes, text/plain)
2018-07-20 16:15 UTC, Mohan Boddu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1610811 None None None Never
Red Hat Bugzilla 1624838 None None None Never

Internal Links: 1610811 1624838

Description Mohan Boddu 2018-07-20 16:15:17 UTC
python-behave failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28220634


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-behave at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-behave will be orphaned. Before branching of Fedora 30,
python-behave will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:15:24 UTC
Created attachment 1466007 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 16:15:29 UTC
Created attachment 1466008 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:15:31 UTC
Created attachment 1466009 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:25:06 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 5 Miro Hrončok 2018-08-10 13:47:12 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 6 Miro Hrončok 2018-08-13 11:59:18 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 7 Jan Kurik 2018-08-14 10:28:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 8 Miro Hrončok 2018-08-16 12:30:49 UTC
Do something now! (This is the unfriendly reminder.)

Comment 9 Miro Hrončok 2018-08-16 15:13:43 UTC
I apologize if my unfriendly reminder was too harsh. It was intended to be stronger than the previous friendly reminders, not to hurt anyone.

That said, this still needs to be taken care of.

Comment 10 Miro Hrončok 2018-08-17 11:49:24 UTC
Leaf packages that still require Python 3.6 one week before Fedora 29 Beta Freeze ([0]) and their FTBFS bug remains in NEW state, will be mass retired. Packages marked as blocked by non-FTBFS bug are excluded from this. [1]

[0] https://fedoraproject.org/wiki/Releases/29/Schedule
[1] https://pagure.io/fesco/issue/1965

Comment 11 Miro Hrončok 2018-08-20 13:59:26 UTC
Note that beta freeze is scheduled for 2018-08-28 so the deadline is tomorrow. You don't need to fix this by tomorrow, a change of state of this bug that indicates you will work on this (e.g. to ASSIGNED) is OK as well.

Comment 12 Miro Hrončok 2018-08-21 11:00:39 UTC
python-docx BRs python-behave, hence I'm not retiring python-behave.

Comment 13 Miro Hrončok 2018-08-27 11:12:49 UTC
python-docx no longer BRs python-behave. hence we could retire this.

Instead, I came up with https://src.fedoraproject.org/rpms/rpm/pull-request/14 that fixes this bug, yet's a bit controversial, so I've promised to wait one week (that'll happen on Wednesday) for arguments against it. Note that it's still less controversial than retirement.

Comment 14 Petr Viktorin 2018-08-27 12:06:56 UTC
Did you mean https://src.fedoraproject.org/rpms/python-behave/pull-request/2 ?

Comment 15 Miro Hrončok 2018-08-27 12:14:48 UTC
yes. bad copy-paste. thanks

Comment 16 Miro Hrončok 2018-08-30 08:31:24 UTC
Merged. Building.

Comment 17 Fedora Blocker Bugs Application 2018-08-30 08:37:06 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Systems with python3-behave installed cannot update to Fedora 29.

Comment 18 Fedora Update System 2018-08-30 08:42:23 UTC
python-behave-1.2.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 19 Fedora Update System 2018-08-30 15:01:14 UTC
python-behave-1.2.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 20 Lukas Ruzicka 2018-09-03 11:43:25 UTC
I can install this update with dnf install python3-behave and updates-testing allowed. If I try to install as python-behave, my Fedora 29 with updates-testing on offers to install python2-behave. Should that be changed too, to get rid of Python 2?

Comment 21 Miro Hrončok 2018-09-03 11:54:54 UTC
The python2-behave is not from updates-testing. Or is it?

It was removed in the update, but dnf still finds it in the "fedora" repo.

Comment 22 Lukas Ruzicka 2018-09-03 12:07:36 UTC
sudo dnf install python-behave
Last metadata expiration check: 0:57:04 ago on Mon 03 Sep 2018 01:07:24 PM CEST.
Error: 
 Problem: problem with installed package python3-behave-1.2.6-1.fc29.noarch
  - package python3-behave-1.2.6-1.fc29.noarch conflicts with python2-behave < 1.2.6 provided by python2-behave-1.2.5-23.fc28.noarch
  - conflicting requests
  - nothing provides python(abi) = 3.6 needed by python3-behave-1.2.5-23.fc28.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 23 Fedora Update System 2018-09-03 12:23:32 UTC
fedora-obsolete-packages-29-21 python-behave-1.2.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 24 Lukas Ruzicka 2018-09-03 13:18:15 UTC
The above mentioned bug provides the fedora-obsolete-packages that will solve this situation. I think the bug is now verified as solved.

Comment 25 Fedora Update System 2018-09-04 09:03:07 UTC
fedora-obsolete-packages-29-21, python-behave-1.2.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 26 Fedora Update System 2018-09-05 01:08:59 UTC
fedora-obsolete-packages-29-21, python-behave-1.2.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.