Bug 1605625 - python-cattrs: FTBFS in Fedora rawhide
Summary: python-cattrs: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cattrs
Version: 29
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F29FTBFS F29BetaFreezeException PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:17 UTC by Mohan Boddu
Modified: 2018-09-21 05:33 UTC (History)
3 users (show)

Fixed In Version: python-cattrs-0.9.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-21 05:33:41 UTC


Attachments (Terms of Use)
build.log (25.04 KB, text/plain)
2018-07-20 16:18 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:18 UTC, Mohan Boddu
no flags Details
state.log (643 bytes, text/plain)
2018-07-20 16:18 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 16:17:57 UTC
python-cattrs failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28220782


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-cattrs at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-cattrs will be orphaned. Before branching of Fedora 30,
python-cattrs will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:18:04 UTC
Created attachment 1466050 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 16:18:07 UTC
Created attachment 1466051 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:18:13 UTC
Created attachment 1466052 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:24:56 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 5 Miro Hrončok 2018-07-29 14:53:13 UTC
Can we retire python-cattrs? Nothing in Fedora seems to depend on it.

Comment 6 Miro Hrončok 2018-08-06 10:21:57 UTC
This is another friendly reminder.

Please take action.

Comment 7 Miro Hrončok 2018-08-10 13:46:56 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 8 Miro Hrončok 2018-08-13 11:58:59 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 9 Jan Kurik 2018-08-14 10:28:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 10 Miro Hrončok 2018-08-16 12:30:36 UTC
Do something now! (This is the unfriendly reminder.)

Comment 11 Miro Hrončok 2018-08-16 15:13:33 UTC
I apologize if my unfriendly reminder was too harsh. It was intended to be stronger than the previous friendly reminders, not to hurt anyone.

That said, this still needs to be taken care of.

Comment 12 Miro Hrončok 2018-08-17 11:49:14 UTC
Leaf packages that still require Python 3.6 one week before Fedora 29 Beta Freeze ([0]) and their FTBFS bug remains in NEW state, will be mass retired. Packages marked as blocked by non-FTBFS bug are excluded from this. [1]

[0] https://fedoraproject.org/wiki/Releases/29/Schedule
[1] https://pagure.io/fesco/issue/1965

Comment 13 Miro Hrončok 2018-08-20 13:59:20 UTC
Note that beta freeze is scheduled for 2018-08-28 so the deadline is tomorrow. You don't need to fix this by tomorrow, a change of state of this bug that indicates you will work on this (e.g. to ASSIGNED) is OK as well.

Comment 14 Miro Hrončok 2018-09-03 17:16:47 UTC
Hi. What's the status?

Comment 15 Eric Smith 2018-09-04 19:53:33 UTC
Still working on it. Apparently the python-hypothesis in F28 is too old. I'll try with Rawhide.

Comment 16 Fedora Blocker Bugs Application 2018-09-07 10:31:32 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Old version blocks update to Fedora 29, requires Python 3.6.

Comment 17 Adam Williamson 2018-09-10 23:27:44 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted (under the block vote at the end of the meeting) as a freeze exception issue as this can prevent upgrades working without the potentially-dangerous --allowerasing , and upgrades typically run without updates-testing so there is a benefit to pushing this stable for folks trying to upgrade at present.

Comment 18 Miro Hrončok 2018-09-13 08:51:29 UTC
This one is the last package. Update to latest upstream fixes the FTBFS. I'm doing it.

Comment 19 Fedora Update System 2018-09-13 10:46:58 UTC
python-cattrs-0.9.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-71449f3212

Comment 20 Fedora Update System 2018-09-13 15:22:13 UTC
python-cattrs-0.9.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-71449f3212

Comment 21 Fedora Update System 2018-09-21 05:33:41 UTC
python-cattrs-0.9.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.