Bug 1605741 - python-kitchen: FTBFS in Fedora rawhide
Summary: python-kitchen: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-kitchen
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1583600 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS PYTHON38 F31FTBFS PYTHON37 1732841
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:46 UTC by Mohan Boddu
Modified: 2019-07-31 22:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 20:19:35 UTC


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2018-07-20 16:46 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:46 UTC, Mohan Boddu
no flags Details
state.log (647 bytes, text/plain)
2018-07-20 16:46 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 16:46:23 UTC
python-kitchen failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28222516


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-kitchen at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-kitchen will be orphaned. Before branching of Fedora 30,
python-kitchen will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:46:29 UTC
Created attachment 1466338 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 16:46:32 UTC
Created attachment 1466339 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:46:35 UTC
Created attachment 1466340 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:59:23 UTC
*** Bug 1583600 has been marked as a duplicate of this bug. ***

Comment 5 Jan Kurik 2018-08-14 09:11:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 6 Miro Hrončok 2018-08-30 11:56:07 UTC
(This package already once built with Python 3.7 with tests disabled to unblock other packages. The "Blocks: PYTHON37" remains here to indicate the failure is Python 3.7 related, yet it does not block the transition to 3.7.)

Comment 7 Miro Hrončok 2019-02-06 11:35:18 UTC
This FTBFS during Fedora 30 as well. According to the FTBFS policy, it should be retired now. Could you please do something about this? It will block us during the Python 3.8 rebase.

Comment 8 Lumír Balhar 2019-05-14 11:25:33 UTC
This package fails to build from source with Python 3.8 as well and it's blocking us.

Comment 10 Ralph Bean 2019-05-14 19:39:41 UTC
Poking at this over here:  https://github.com/fedora-infra/kitchen/pull/31

Seeking rights to cut a release of this as I'm not in the fedora-infra github group any more.

Comment 11 Ralph Bean 2019-05-14 20:14:22 UTC
OK, I hit the same screwy test failures inside of mock that Toshio grappled with in https://bugzilla.redhat.com/show_bug.cgi?id=1583600.

I'm going to disable the tests.


Note You need to log in before you can comment on or make changes to this bug.