Bug 1605788 - python-myhdl: FTBFS in Fedora rawhide
Summary: python-myhdl: FTBFS in Fedora rawhide
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-myhdl (Show other bugs)
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
Assignee: Filipe Rosset
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: F29FTBFS F29BetaFreezeException PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:59 UTC by Mohan Boddu
Modified: 2018-09-21 05:30 UTC (History)
3 users (show)

Fixed In Version: python-myhdl-0.10-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-21 05:30:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2018-07-20 16:59 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:59 UTC, Mohan Boddu
no flags Details
state.log (639 bytes, text/plain)
2018-07-20 16:59 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 16:59:40 UTC
python-myhdl failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28222946


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-myhdl at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-myhdl will be orphaned. Before branching of Fedora 30,
python-myhdl will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:59:46 UTC
Created attachment 1466471 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 16:59:49 UTC
Created attachment 1466472 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:59:52 UTC
Created attachment 1466473 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:26:53 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 5 Miro Hrončok 2018-08-06 10:22:37 UTC
This is another friendly reminder.

Please take action.

Comment 6 Miro Hrončok 2018-08-10 13:47:37 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 7 Miro Hrončok 2018-08-13 11:59:51 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 8 Filipe Rosset 2018-08-13 12:15:09 UTC
Hi Miro, I was on vacations, will take a look in this issue during this week, thanks for the bug report.

Comment 9 Jan Kurik 2018-08-14 11:10:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 10 Miro Hrončok 2018-08-30 11:21:59 UTC
Filipe, any news?

Comment 11 Fedora Blocker Bugs Application 2018-09-07 10:31:39 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Old version blocks update to Fedora 29, requires Python 3.6.

Comment 13 Fedora Update System 2018-09-09 00:01:23 UTC
python-myhdl-0.10-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-612468ecff

Comment 14 Miro Hrončok 2018-09-09 18:16:12 UTC
Thank You!

Comment 15 Fedora Update System 2018-09-09 20:23:06 UTC
python-myhdl-0.10-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-612468ecff

Comment 16 Adam Williamson 2018-09-10 23:29:04 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted (under the block vote at the end of the meeting) as a freeze exception issue as this can prevent upgrades working without the potentially-dangerous --allowerasing , and upgrades typically run without updates-testing so there is a benefit to pushing this stable for folks trying to upgrade at present.

Comment 17 Fedora Update System 2018-09-21 05:30:39 UTC
python-myhdl-0.10-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.