Bug 160580 - Trident Cyberblade (generic) driver causing Whitescreen at install
Trident Cyberblade (generic) driver causing Whitescreen at install
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 17:50 EDT by Andreas Johansson
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-25 16:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Johansson 2005-06-15 17:50:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
During GUI install anaconda autoprobes correctly and tries to start GUI install. System hangs with white screen.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start FC4 installer in GUI mode
2.
3.
  

Actual Results:  System hangs with white screen.


Expected Results:  GUI installer should start.

Additional info:

Im not new to having problems with this driver, below is my computer spec in short and problems using Red Hat and Fedora Core:

Compaq Evo N150 laptop
Pentium 3 800mhz
Trident Cyberblade i1 graphic card 8mb shared memory
320mb ram (8mb Shared)
1024x768 LCD (can only work in this resolution)


Redhat 8 Anaconda autoprobes wrong driver choosing "vesa" GUI install works fine for me with this vesa driver.

Fedora Core 1 Anaconda autoprobes correct driver "Trident cyberblade (generic)" and "unknown" monitor, GUI install shows black screen. Workaround for me was to press ctrl+alt+F1 and then ctrl+alt+7 and GUI install works after that.

Fedora Core 2 Same as FC1 and same workaround.

Fedora Core 3 anaconda does the same autoprobe but my workaround does not work. Workaround instead is to connect a external vga monitor to my laptop and then do the ctrl+alt+F1 followed by ctrl+alt+F7. GUI install starts and I can remove the external vga monitor. I also have to use the above trick to start the laptop the first time before I can setup the rigth settings for my LCD Display.

I have also seen that the stock FC3 Totem Player cant show anything at all (tried different video files of different formats) while Mplayer can. I trided to change driver to vesa and after that Totem player works fine.

Fedora Core 4 anaconda autoprobes driver Trident Cyberblade (Generic) and unknown monitor. GUI starts and but shows only a white screen. Text mode install works but first startup does the same white screen.

Possible solution: Anaconda should use vesa driver for this cards untill driver is working.

Question: Is there a way to force anaconda to use a specific driver for vga?

This migth be a duplicate bug, but I havent seen it for FC4 and since I have some experince with all FC releases and this I thougt it migth be of interest. Im also kinda new to bugzilla and how to post bugs. Hope this helps you to help me since I cant change my graphic card in this computer.
Comment 1 Samvinesh Christopher 2005-06-16 10:14:45 EDT
I tried with Trident Blade 3D and Trident 9680. Both showed white screen.
Comment 2 James Bridge 2005-06-16 12:11:03 EDT
I have the Trident Cyberblade/i1 card built in to a cheapish motherboard and get
exactly the same fault with FC4; no problem with FC3.

I also noticed a problem with FC4 installer not finding a "tty" - couldn't see
details! 
Comment 3 Samvinesh Christopher 2005-06-16 12:37:46 EDT
Refer https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160666
Serial mouse is not working. 

May be related to not finding the "tty"S0/1
Comment 4 Brian 2005-06-16 22:12:46 EDT
I experienced this same white screen behavior with the Trident card in a Toshiba
Satellite 1805-S273.  No issues with FC3.
Comment 5 Bennett Feitell 2005-06-17 23:28:35 EDT
Same with Winbook XLi Trident Cyber 9397
Fn-F2(LCD/CRT) toggle brings things up correctly if I twiddle it a few times.
NOTE: this is the built in bios based LCD/CRT toggle, (Function-key)-F2.
This allows install to continue.  Other problems remain however...

Console mode is corrupted (garbled) when switched to from X.  Works fine in FC3.
currently vga=0x317 in grub.conf and 1024x768x24 in xorg.conf tried disabling
DPMS, makes no difference.  

lspci -vv
00:02.0 VGA compatible controller: Trident Microsystems Cyber 9397 (rev f3)
(prog-if 00 [VGA])
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 9
        Memory at fe400000 (32-bit, non-prefetchable) [size=4M]
        Memory at fede0000 (32-bit, non-prefetchable) [size=128K]
        Memory at fe800000 (32-bit, non-prefetchable) [size=4M]

Comment 6 James Bridge 2005-06-22 13:50:16 EDT
This problem is caused by the /usr/X11R6/lib/modules/libvgahw.a file in FC4.
Replacing this with the equivalent from FC3 gives correct display both for the
GUI and the text consoles.

This bug seems to be the same as #160500 and #161047 - all connected with the
Trident CyberBlade video card.
Comment 7 Mike A. Harris 2005-06-22 17:29:37 EDT
Please review bug number 161242 everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.
Comment 8 Andreas Johansson 2005-06-22 19:41:54 EDT
I could probably test this after doing a text install. But how would I do to get
this rigth at install? I use the FC4 DVD as a folder on a FTP to install from.
Comment 9 Mike A. Harris 2005-06-23 13:17:01 EDT
You have to do a text mode install if you're hanging at GUI install time.
Please consult Fedora docs and/or mailing list if you require assistance
enabling a text mode install.

Hope this helps.
Comment 10 Mark A. Schwenk 2005-06-25 08:29:34 EDT
I had this problem on one of my systems based on the VIA EPIA 5000 motherboard
with the Trident Cyberblade (generic) onboard video.

I upgraded my FC3 system in text mode to FC4 and experienced all the problems
reported here.

I then applied the test version of /usr/X11R6/lib/modules/libvgahw.a linked in
the solution at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242 and
found the my problems with X were resolved.
Comment 11 Mike A. Harris 2005-06-25 16:21:38 EDT

*** This bug has been marked as a duplicate of 161242 ***
Comment 12 Jim Cornette 2005-06-26 09:00:32 EDT
In reference to comment 8

Doing a text install and then replacing the libvgahw.a file in single user mode
will still allow firstboot to come up after you replace the file and reboot into
regular mode.
A message from the fedora users list is below. You might be able to replace this
file in other ways just after th install is completed and before rebooting, but
this was my first thought.

https://www.redhat.com/archives/fedora-list/2005-June/msg04722.html

I hope this helps. Others have tried this with success.
Comment 13 Jan Kohout 2005-08-01 17:24:31 EDT
Great! It works! Just an overwriting the file libvgahw.a is enough. I actually
upgraded from FC3 to FC4 without CD (the manual used sequence of commands
including `yum upgrade`). 
Fortunately I was able to change to text console and set starting level to 3.
Since that time I am using text browsers :-) such as `lynx` or `links`. As I
see now, it was not so good idea to use upgrade without a CD. Thanks a lot for
the `libvgahw.a` file in the page linked above.
Jan Kohout

Note You need to log in before you can comment on or make changes to this bug.