Bug 16059 - utilities still depend on inetd.conf
utilities still depend on inetd.conf
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Preston Brown
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-12 08:22 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 19:04:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-08-12 08:22:49 EDT
tcpdchk and tcpdmatch still depend on inetd.conf, don't work with xinetd.
Comment 1 Glen Foster 2000-08-13 16:09:14 EDT
This defect is considered MUST-FIX for Winston Gold-release.
The entire transformation from inetd.conf -> xinetd must be done for the
release.
Comment 2 Jeff Johnson 2000-08-14 13:50:34 EDT
Fixed (by removing tcpdchk/tcpdmatch) in tcp_wrappers-7.4-15.

Better fix would be to rewrite tcpdchk/tcpdmatch in perl/python, however.
Comment 3 R P Herrold 2001-02-17 19:04:23 EST
from redhat-devel today:

> Whats tcpdchk ? Dont have it and locate finds nothing.... (part of
> tcp_wrappers ? rpm -qil doesn't show it)...
 
[herrold@swampfox herrold]$ rpm -qf `which tcpdchk`
tcp_wrappers-7.6-9
 
... uggh -- you've found a problem in the beta ... I'll verify
and file a bugzilla  -- they've omitted tcpdchk, looks like
...                                                                  

--------------------------------

Rationale:

Oops.  tcpdchk does NOT use inetd.conf -- it uses /etc/hosts.allow, hosts.deny,
and friends in DNS.  

It is truly needed for auditting wrappers ...

Plase reverse this omission...  I suggest that this is MUST FIX for 7.1 gold ...
Comment 4 R P Herrold 2001-02-17 19:24:46 EST
oopps -- my mistake -- typing before thinking all the way through -- 

I'll file a separate RFE for a tcpdchk like replacement, and do some coding.

Note You need to log in before you can comment on or make changes to this bug.