Bug 160610 - eclipse will not launch - error could not be logged
eclipse will not launch - error could not be logged
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 22:09 EDT by joe
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joe 2005-06-15 22:09:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
[joe@Knoppix books]$ eclipse
java.io.IOException: The FrameworkAdaptor object could not perform the operation   at org.eclipse.osgi.framework.adaptor.core.AbstractFrameworkAdaptor.initializeStorage() (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.Framework.initialize(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.Framework.Framework(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.OSGi.OSGi(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.6.0.0)
   at org.eclipse.core.launcher.Main.invokeFramework(java.lang.String[], java.net.URL[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.basicRun(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
!SESSION 2005-06-15 21:57:51.431 -----------------------------------------------eclipse.buildId=I20050401-1645
java.fullversion=GNU libgcj 4.0.0 20050519 (Red Hat 4.0.0-8)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86 -data /home/joe/workspace

!ENTRY org.eclipse.osgi 2005-06-15 21:57:51.433
!MESSAGE Startup error
!STACK 1
java.lang.RuntimeException: The FrameworkAdaptor object could not perform the operation
   at org.eclipse.osgi.framework.internal.core.Framework.initialize(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.Framework.Framework(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.osgi.framework.internal.core.OSGi.OSGi(org.eclipse.osgi.framework.adaptor.FrameworkAdaptor) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.6.0.0)
   at org.eclipse.core.launcher.Main.invokeFramework(java.lang.String[], java.net.URL[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.basicRun(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

(eclipse:18820): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",

(eclipse:18820): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",


Version-Release number of selected component (if applicable):
eclipse-ecj-3.1.0_fc-0.M6.22
eclipse-platform-3.1.0_fc-0.M6.22
eclipse-pde-devel-3.1.0_fc-0.M6.22
eclipse-jdt-devel-3.1.0_fc-0.M6.22
eclipse-cdt-3.0.0_fc-0.M6.7
eclipse-platform-devel-3.1.0_fc-0.M6.22
eclipse-changelog-2.0.1_fc-21
eclipse-pde-3.1.0_fc-0.M6.22
eclipse-jdt-3.1.0_fc-0.M6.22
eclipse-bugzilla-0.1.0_fc-16
eclipse-pydev-0.9.3_fc-7

How reproducible:
Always

Steps to Reproduce:
1. launch from Applications menu
2. launch from command line
3.
  

Actual Results:  see description above

Expected Results:  the eclipse IDE

Additional info:
Comment 1 Andrew Overholt 2005-06-16 09:43:04 EDT
Try rm -rf ~/.eclipse and possibly a new workspace.
Comment 2 Andrew Overholt 2005-09-21 10:34:59 EDT
Any news here?  Does it still not work?
Comment 3 joe 2005-09-21 16:38:15 EDT
works just fine with the reinstall - thanks
Comment 4 Andrew Overholt 2005-09-21 17:02:02 EDT
Great.  Closing.

Note You need to log in before you can comment on or make changes to this bug.