Bug 160631 - russian printing requires the same setting as CJK
russian printing requires the same setting as CJK
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-printer (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 156322 Russian
  Show dependency treegraph
 
Reported: 2005-06-16 04:08 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-715
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-06-16 04:08:51 EDT
Description of problem:
Russian printing is not possible with the default setting. However, changing the
settings similar to CJK will allow applications to print russian characters
properly.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-1

How reproducible:
Always

Steps to Reproduce:
1.in ru_RU.UTF-8 run system-config-printer 
2.set up the printer and print ps file containing russian characters
3.
  
Actual results:
russian characters are not printed (blank)

Expected results:
russian characters gets printed

Additional info:
Modified the setting in system-config-printer manually similar to CJK will allow
russian to print properly.
Comment 1 Leon Ho 2005-07-24 23:55:10 EDT
Russian main feature is ACKed (bug 130962), but it is missing acks on this
individual bug. Confirmed with PM/QA/Devel stakeholders on adding back the
missing acks and add to U2CanFix tracker.
Comment 2 Tim Waugh 2005-07-27 08:26:56 EDT
Need information on how to do this.  Here is what the 'cjktexttops' filter does
for each "special" locale:

MPAGE_PARAMS=-m18lr36bt
if [ "x$LANG" == "xja_JP" ]; then
  mpage -b$PAPERSIZE -1 -o $MPAGE_PARAMS -P- "$INPUT"
elif [ "x$LANG" == "xko_KR" ]; then
  h2ps -q -1 -p -D "$INPUT"
elif [ "x$LANG" == "xzh_CN" ]; then
  mpage -b$PAPERSIZE -1 -o $MPAGE_PARAMS -P- "$INPUT" | bg5ps -en gb2312 -nps y
elif [ "x$LANG" == "xzh_TW" ]; then
  mpage -b$PAPERSIZE -1 -o $MPAGE_PARAMS -P- "$INPUT" | bg5ps -en big5 -nps y
else
  # unknown locale
  /usr/lib/cups/filter/texttops "$@"
fi

What should it do for "ru_RU"?
Comment 4 Leon Ho 2005-07-27 11:33:36 EDT
Tim, sorry for not being clearer. For this bug we are not refering to text
printing for Russian but it is refering to the graphical for enabling "re-render
postscript" option by default. This fix should not be more than 5 lines patch.
This patch is needed mainly for firefox printing.
Comment 5 Tim Waugh 2005-07-27 12:03:56 EDT
Can you give me a more detailed "how to reproduce"?  What precisely is not
working now that you expect "re-render postscript" to fix?

Several different files need changing for this, so it is important to have a
test case so that I can really see that it works.
Comment 6 Tim Waugh 2005-07-27 12:10:09 EDT
Um, also -- why do we need an update for this at all?  If it is just a case of
twiddling a configuration setting, there is a clear work-around.
Comment 7 Lawrence Lim 2005-07-29 01:55:25 EDT
Based on my printer setup, the following are my steps to reproduce:

On the assumption we dont have a printer queue set up. Set to next section if
print queue has been setup.
1. in gnome-terminal, LANG=ru_RU.UTF-8 system-config-printer
2. click on 'New' to create a new print queue
3. click 'Forward' to create a new print queue
4. click 'Forward' to accept the default queue name
5. select 'Networked JetDirect' as the queue type
6. printer name 'gryffindor' (for BNE office)
7. click forward to select the printer model
8. click ok to finish the setup

After the print queue sets up,
1. edit the print queue by clicking on Edit
2. go to the Driver Option tab

Actual Result:
'Prerender Postscript' is not selected

Expected Result:
'Prerender Postscript' is selected

Additional Info:
Reason why russian cant print is because 'Prerender Postscript' option is not
selected.
Comment 8 Lawrence Lim 2005-07-29 02:32:56 EDT
To try the actual printing,

1. starts up firefox
2. go to http://www.google.com.ru/ search for linux
3. print the result page to printer
Comment 10 Tim Waugh 2005-08-02 06:25:10 EDT
llch: please verify that the changes in system-config-printer-0.6.138-1 in
Fedora Core devel rectify the problem there.  Then I can backport them to
0.6.116.  Thanks.
Comment 11 Akira TAGOH 2005-08-02 08:52:46 EDT
Sorry for the confusion, but this problem may seems to depend on which printer
are used. We, Tokyo office has a Canon LBP-880 which requires lisp4v driver to
get it working. and when I configure it with s-s-p on ru_RU.UTF-8 and doing a
test printing, it didn't work at all and said "There was a problem sending CUPS
test page to 'printer' queue: lpr: error - unable to print file:
server-error-service-unavailable".  However I can get it working with turning on
"Assume Unknown Data is Text" only. and the Russian printing from firefox works
fine without enabling "Prerender Postscript" option. *OR* when I turned on
"Prerender Postscript" option only instead of enabling "Assume Unknown Data is
Text" option, it also works though.
Lawrence or Leon, is this a symptom of your problem as well?
Comment 12 Tim Waugh 2005-08-02 09:09:58 EDT
server-error-service-unavailable would seem to be a transient error of some
kind.  It indicates that the client could not connect to the server.

If that problem is reproducible, it sounds more like a CUPS bug than a
system-config-printer problem, and is not to do with printer settings at all.
Comment 13 Akira TAGOH 2005-08-02 09:15:58 EDT
it sometimes appeared but it wasn't related to this. when I tried to configure a
printer and printing some times, actually the Russian printing works without any
additional options here. Sorry, ignore that error for now.
This problem surely depends on the printer anyway.
Comment 14 Tim Waugh 2005-08-02 09:18:29 EDT
Closing.
Comment 15 Akira TAGOH 2005-08-02 09:31:07 EDT
hmm, closing it as NOTABUG looks like to me an immediate decision. just reminds
me why we've turned on some options, including "Prerender Postscript" for CJK
is, there is the printers which doesn't have CJK fonts in the printers. right
now I'm quite not sure whether or not this problem is rare. if mine is rare, it
means most people won't get the Russian printing working then. so Tim, just a
question for you, does the Russian printing work for you as well? and which
printer are you using BTW?
Comment 16 Lawrence Lim 2005-08-03 00:49:27 EDT
Using system-config-printer-0.6.116.4-1 from  dist-4E-qu-candidate to create a
new printer profile in the ru_RU locale, I was able to print CJK and Russian
correctly from firefox. So I dont think it is not a bug.


Thanks.
Comment 17 Lawrence Lim 2005-08-03 01:25:12 EDT
Tried to create a new profile in CJK locale with the previous CJK and Russian
printout. No regression observed.
Comment 18 Lawrence Lim 2005-08-03 02:19:33 EDT
Used to russian printer profile to print multi-lingual document (CJKI + Russian)
on gedit and gtkhtml (html and non-html mode). No regression error found.
Comment 20 Red Hat Bugzilla 2005-10-05 13:27:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-715.html

Note You need to log in before you can comment on or make changes to this bug.