Bug 1606466 - synfigstudio: FTBFS in Fedora rawhide [NEEDINFO]
Summary: synfigstudio: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: synfigstudio
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1676105 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS 1551327 1705346
TreeView+ depends on / blocked
 
Reported: 2018-07-20 20:08 UTC by Mohan Boddu
Modified: 2019-05-12 10:40 UTC (History)
6 users (show)

Fixed In Version: synfigstudio-1.2.2-3.fc30 synfigstudio-1.2.2-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-12 01:22:08 UTC
luya: needinfo? (gwync)


Attachments (Terms of Use)
build.log (12.04 KB, text/plain)
2018-07-20 20:08 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 20:08 UTC, Mohan Boddu
no flags Details
state.log (639 bytes, text/plain)
2018-07-20 20:08 UTC, Mohan Boddu
no flags Details
updated spec (7.89 KB, text/plain)
2019-01-01 21:40 UTC, Luya Tshimbalanga
no flags Details

Description Mohan Boddu 2018-07-20 20:08:41 UTC
synfigstudio failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28235851


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix synfigstudio at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
synfigstudio will be orphaned. Before branching of Fedora 30,
synfigstudio will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 20:08:46 UTC
Created attachment 1468345 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 20:08:50 UTC
Created attachment 1468346 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 20:08:54 UTC
Created attachment 1468347 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 08:53:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Michael Cronenworth 2018-08-28 21:48:07 UTC
This is rebuild is also required for ImageMagick 6.9.10.

Comment 6 Luya Tshimbalanga 2019-01-01 21:40:40 UTC
Created attachment 1517806 [details]
updated spec

Scratch build result: https://koji.fedoraproject.org/koji/taskinfo?taskID=31763494
For some odd reasons, 

synfig(13340) [13:37:26] warning: Cannot open ./synfig_modules.cfg
synfig(13340) [13:37:26] warning: Cannot open /builddir/.local/share/synfig/synfig_modules.cfg

Comment 7 Luya Tshimbalanga 2019-01-01 21:42:29 UTC
@Gwyn,
Could you check what is really happening? It looks like the failure occurred after some changes in F29 development.

Thanks

Comment 8 Gwyn Ciesla 2019-05-02 13:15:56 UTC
*** Bug 1676105 has been marked as a duplicate of this bug. ***

Comment 9 Martin 2019-05-03 02:18:39 UTC
It looks like synfig is not built properly or has a bug. The error message while building synfigstudio in Fedora 30 mock environment:

...
synfig(11434) [19:05:43] info: Loading mod_libavcodec..                        
/usr/bin/synfig: warning: Unable to find module "mod_libavcodec" (file not found)
synfig(11434) [19:05:43] info: Loading mod_yuv420p..                           
synfig(11434) [19:05:43] info: Loading mod_svg..                               
synfig(11434) [19:05:43] info: Loading file: synfig_icon.sif                  
synfig(11434) [19:05:43] info: Loading file: ./logo.sif
/usr/include/c++/9/bits/basic_string.h:1067: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::reference = char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
make: *** [Makefile:1416: 128x128/synfig_icon.png] Aborted (core dumped)

The command in image/Makefile line 1416 that core dumps (inside 'image' directory):
  synfig -q synfig_icon.sif -o 128x128/synfig_icon.png -time 0 -w 128 -h 128

Not sure it's even related to mod_libavcodec being disabled (requires new ffmpeg which exists in rpmfusion per https://github.com/synfig/synfig/issues/744)

Maybe try to debug synfig using just synfig_icon.sif file copied somewhere.

Comment 10 Martin 2019-05-03 02:28:41 UTC
I tried running synfig (1.2.1) from Fedora 27 and it works. I actually had to copy synfig_icon.sif, synfig_icon.svg, and logo.sif files into Fedora 27.

The command I ran (note that there are two dashes before 'time'):

synfig -q synfig_icon.sif -o synfig_icon.png --time 0 -w 128 -h 128

So it's definitely synfig that's a problem, and synfigstudio build just fails because of that.

Comment 11 Fedora Update System 2019-05-03 21:14:08 UTC
synfig-1.2.2-4.fc30 synfigstudio-1.2.2-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-aedac89554

Comment 12 Fedora Update System 2019-05-03 21:14:15 UTC
synfig-1.2.2-4.fc29 ETL-1.2.2-2.fc29 synfigstudio-1.2.2-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ff28d8481b

Comment 13 Fedora Update System 2019-05-04 01:58:05 UTC
synfig-1.2.2-4.fc30, synfigstudio-1.2.2-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-aedac89554

Comment 14 Fedora Update System 2019-05-04 02:58:35 UTC
ETL-1.2.2-2.fc29, synfig-1.2.2-4.fc29, synfigstudio-1.2.2-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ff28d8481b

Comment 15 Fedora Update System 2019-05-12 01:22:08 UTC
synfig-1.2.2-4.fc30, synfigstudio-1.2.2-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-05-12 10:40:06 UTC
ETL-1.2.2-2.fc29, synfig-1.2.2-4.fc29, synfigstudio-1.2.2-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.