Bug 1606644 - vifm: FTBFS in Fedora 29: src/modes/file_info.c:329: undefined reference to `major'
Summary: vifm: FTBFS in Fedora 29: src/modes/file_info.c:329: undefined reference to `...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vifm
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Boeckel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1676188 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 21:00 UTC by Mohan Boddu
Modified: 2019-07-20 03:46 UTC (History)
3 users (show)

Fixed In Version: vifm-0.8.2-8.fc31 vifm-0.8.2-8.fc30 vifm-0.8.2-7.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-20 02:33:39 UTC


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2018-07-20 21:00 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 21:00 UTC, Mohan Boddu
no flags Details
state.log (607 bytes, text/plain)
2018-07-20 21:00 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 21:00:23 UTC
vifm failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28238803


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix vifm at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
vifm will be orphaned. Before branching of Fedora 30,
vifm will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 21:00:27 UTC
Created attachment 1468862 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 21:00:31 UTC
Created attachment 1468863 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 21:00:34 UTC
Created attachment 1468864 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 08:49:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Petr Pisar 2019-07-11 12:39:48 UTC
*** Bug 1676188 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2019-07-11 12:53:37 UTC
Glibc 2.25 stopped including <sys/sysmacros.h> transitively. Applications are supposed to include the header file explicitly if they need major() or minor() macros.

vimf upstream fixed it after 0.9 release in commit:

commit df383c6adab6342cbb2177527917caed7400b207
Author: xaizek <xaizek@openmailbox.org>
Date:   Fri Jul 7 20:25:54 2017 +0300

    Conditionally display device ID in file info
    
    Check whether major and minor macros are available, they aren't
    defined in POSIX.
    
    Thanks to Robert Sarkozi.

by not using the macros if they are not defined.

Comment 7 Petr Pisar 2019-07-11 13:13:34 UTC
I applied the upstream's patch.

Comment 8 Fedora Update System 2019-07-11 13:31:12 UTC
FEDORA-2019-3fd39d849d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3fd39d849d

Comment 9 Fedora Update System 2019-07-11 13:31:19 UTC
FEDORA-2019-2b113a4956 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b113a4956

Comment 10 Fedora Update System 2019-07-12 02:15:56 UTC
vifm-0.8.2-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3fd39d849d

Comment 11 Fedora Update System 2019-07-12 06:09:36 UTC
vifm-0.8.2-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b113a4956

Comment 12 Fedora Update System 2019-07-20 02:33:39 UTC
vifm-0.8.2-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-07-20 03:46:54 UTC
vifm-0.8.2-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.