Bug 160677 - ide-tape module not working in kernel-2.4.22-1.2199.4.legacy
ide-tape module not working in kernel-2.4.22-1.2199.4.legacy
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora Legacy
Classification: Retired
Component: kernel (Show other bugs)
fc1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Fedora Legacy Bugs
DEFER
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-16 11:51 EDT by James Kosin
Modified: 2007-04-18 13:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 11:16:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug log from ide-tape module (143.68 KB, text/plain)
2005-06-16 11:51 EDT, James Kosin
no flags Details

  None (edit)
Description James Kosin 2005-06-16 11:51:58 EDT
Description of problem:
  My IDE tape drive does not work anymore with the new kernel.  It worked with 
the 2.4.22-1.2199 version before.

Version-Release number of selected component (if applicable):


How reproducible:
  Always reproducable.

Steps to Reproduce:
1.  mt status
2.
3.
  
Actual results:
  /dev/tape: Device or resource busy

Expected results:
  Expected status information on the tape drive.

Additional info:
  pci info
------------
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 
03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 (rev 10)
00:0a.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
00:0b.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 
5c)

  hdd info  (IDE Tape Drive)
------------
ide-tape version 1.17c
tape
HP COLORADO 20GB
ht0
name			value		min		max		mode
----			-----		---		---		----
avg_speed               0               0               65535           r
buffer                  432             0               32767           r
current_speed           34              0               70              rw
debug_level             5               0               65535           rw
dsc_overlap             1               0               1               rw
init_speed              34              0               70              rw
io_32bit                0               0               3               rw
keepsettings            0               0               1               rw
nice1                   1               0               1               rw
number                  3               0               3               rw
pio_mode                write-only      0               255             w
pipeline                6336            32              2097120         rw
pipeline_head_speed_c   0               0               65535           r
pipeline_head_speed_u   0               0               65535           r
pipeline_max            12672           32              2097120         rw
pipeline_min            32              32              2097120         rw
pipeline_pending        0               0               2097120         r
pipeline_used           0               0               2097120         r
slow                    0               0               1               rw
speed                   650             0               65535           r
stage                   32              0               63              r
tdsc                    100             50              400             rw
unmaskirq               0               0               1               rw
using_dma               0               0               1               rw
Comment 1 James Kosin 2005-06-16 11:51:58 EDT
Created attachment 115547 [details]
debug log from ide-tape module
Comment 2 Pete Zaitcev 2005-06-16 15:45:39 EDT
I have no idea what Fedora Legacy people managed to break exactly,
but in any case nobody should use ide-tape. Use ide-scsi.
Comment 3 James Kosin 2005-06-16 17:08:07 EDT
ide-scsi is broken for me as well.... otherwise, I would use it.
Comment 4 James Kosin 2005-06-20 14:47:07 EDT
Hmmm.... It started working all by itself all of a sudden.  I'll keep track of 
this ...... maybe a bad tape?  or drive in need of cleaning soon.
Comment 5 Pekka Savola 2005-06-29 09:10:28 EDT
closing as NOTABUG, reopen if needed.
Comment 6 James Kosin 2005-07-07 10:24:51 EDT
I changed tapes, still no luck.

I started playing around with the settings...  turned DMA for the drive back on 
using hdparm.  Did not work; so, I used the killer ide reset command with 
hdparam.  They are not kidding when they say it is dangerous.  Oops....

I rebooted the system.
Everything started working again with the tape drive.

Will update after a tape change to make sure changing tapes is not causing the 
problem.

Comment 7 James Kosin 2005-07-08 12:39:18 EDT
Ok,

Changed tape today!  Guess what!  I got the tape drive is busy signal 
again....  I did an hdparm -w /dev/hdc on the tape drive, rebooted after the 
Ooops.. and the tape drive is working again.

This seems to be a problem with changing medium or tapes that causes the 
problem.  Right now, the only work-around I have is to do the hdparm command, 
and reset the box.

I've tried just resetting before; but, it never works, or only works 
intermittently.
Comment 8 Marc Deslauriers 2005-07-30 20:26:06 EDT
If you go back to 2.4.22-1.2199, does it start working again?
Comment 9 James Kosin 2005-08-01 09:17:31 EDT
Yes... If I go back, it works; but there is (or shouldn't be) any difference in 
how the module works in 1.2199 or the legacy builds.

Right now causing the module to Ooops and reboot the system seems to be my only 
work-around.
Comment 10 David Eisenstein 2005-10-10 06:11:28 EDT
Reporter:  Have you tried upgrading to kernel-2.4.22-1.2199.5.legacy?

If so, does the problem continue?
Comment 11 James Kosin 2005-10-14 10:21:38 EDT
Nope, still not working.
I'll try an troubleshoot this problem more proactively this month; since, I do 
need the tape drive working again.
Comment 12 Pekka Savola 2005-11-16 08:27:30 EST
This doesn't seem to be important enough to fix just on its own, so mark it DEFER.
Comment 13 James Kosin 2006-05-24 13:20:27 EDT
I lowered the priority, I don't think it is of any improtance to anyone but me.
Comment 14 David Eisenstein 2006-05-28 03:35:49 EDT
Just a thought, James.  The most recently-released FL kernel is 2.4.22-1.2199.8.
 Does upgrading to this kernel affect this issue at all?
Comment 15 James Kosin 2006-08-18 18:51:21 EDT
ide-tape: Block location is unknown to the tape
ide-tape: ht0: I/O error, pc =  0, key =  3, asc = 30, ascq =  0
ide-tape: ht0: drive not ready
ide-tape: Block location is unknown to the tape
ide-tape: Block location is unknown to the tape
ide-tape: ht0: I/O error, pc =  0, key =  3, asc = 30, ascq =  0
ide-tape: ht0: drive not ready
ide-tape: Block location is unknown to the tape
ide-tape: Block location is unknown to the tape
ide-tape: ht0: I/O error, pc =  0, key =  3, asc = 30, ascq =  0
ide-tape: ht0: drive not ready
ide-tape: Block location is unknown to the tape

Note You need to log in before you can comment on or make changes to this bug.