Bug 1606775 - yum: FTBFS in Fedora rawhide
Summary: yum: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FTBFS 1585626
TreeView+ depends on / blocked
 
Reported: 2018-07-20 21:34 UTC by Mohan Boddu
Modified: 2019-02-11 20:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-11 20:55:01 UTC


Attachments (Terms of Use)
build.log (13.96 KB, text/plain)
2018-07-20 21:35 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 21:35 UTC, Mohan Boddu
no flags Details
state.log (611 bytes, text/plain)
2018-07-20 21:35 UTC, Mohan Boddu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1600444 None CLOSED Wrong conflicts between dnf and yum prevents upgrade 2019-02-11 15:54:23 UTC

Internal Links: 1600444

Description Mohan Boddu 2018-07-20 21:34:53 UTC
yum failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28241079


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix yum at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
yum will be orphaned. Before branching of Fedora 30,
yum will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 21:35:02 UTC
Created attachment 1469212 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 21:35:06 UTC
Created attachment 1469213 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 21:35:09 UTC
Created attachment 1469214 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 08:46:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Miro Hrončok 2018-08-20 14:51:48 UTC
This IMHO blocks upgrade to F29:

 Problem 17: package dnf-yum-4.0.3.2.0-2.fc29.noarch conflicts with yum provided by yum-3.4.3-518.fc29.noarch
  - problem with installed package yum-3.4.3-517.fc28.noarch
  - problem with installed package dnf-yum-2.7.5-12.fc28.noarch
  - yum-3.4.3-517.fc28.noarch does not belong to a distupgrade repository
  - dnf-yum-2.7.5-12.fc28.noarch does not belong to a distupgrade repository

Comment 6 Zbigniew Jędrzejewski-Szmek 2018-08-28 19:36:55 UTC
Yep, I'm seeing the same error. But I think the upgrade conflict might be caused by something different than the ftbfs:

$ rpm -q --conflicts dnf-yum
yum
$ rpm -q dnf-yum
dnf-yum-4.0.3.2.0-2.fc29.noarch

So it looks like dnf-yum made a boo boo here. I'll file a bug.

Comment 7 Kevin Fenzi 2019-02-11 20:55:01 UTC
Fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=1208006


Note You need to log in before you can comment on or make changes to this bug.