Bug 160713 - Missing/Incorrect BuildRequires
Missing/Incorrect BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecj (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-16 16:20 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 14:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2005-06-16 16:20:43 EDT
During a test rebuild of ecj-3.1-0.M4.9 in the mock builder, the following
problem manifests itself:

+ find -name '*.class' -or -name '*.properties' -or -name '*.rsc'
+ xargs jar cf ../../../ecj-2.1.3.jar
xargs: jar: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.45084 (%build)

The reason is, that the Required libgcj installs fastjar, but doesn't set up the
correct symlink with the alternatives system.
This is done by the java-$ver-compat package, which is not being installed.

According to nasrat the best way of dealing with this issue is dropping the
BuildRequires for gcc-java and libgcj and just setting a BuildRequire for
java-$ver-compat, or even better the virtual java-devel package which is
provided by the java-compat package. This will fix the alternatives problem and
pull in gcj and libgcj as well.
Comment 1 Thomas Fitzsimmons 2005-10-01 17:29:30 EDT
Gary, have we done this already with the java-gcj-compat virtual provide you
created?
Comment 2 Gary Benson 2005-10-03 05:14:03 EDT
This should have been fixed in eclipse one way or another.
Comment 3 Thomas Fitzsimmons 2005-10-03 10:42:41 EDT
Andrew, can you confirm/deny/close this bug?
Comment 4 Andrew Overholt 2005-10-03 10:46:08 EDT
We currently have this in eclipse.spec:

BuildRequires:  java-gcj-compat-devel >= 1.0.33

Gary, is that correct?
Comment 5 Gary Benson 2005-10-03 10:57:32 EDT
That would do it, but you probably should have:

BuildRequires: java

as well, just in case you ever delete the gcj-specific stuff.
Comment 6 Andrew Overholt 2005-10-03 10:58:39 EDT
Yeah, I have that in the non-gcj_support %if block.

I don't know what to do now.  Shall we close this?
Comment 7 Gary Benson 2005-10-03 11:35:40 EDT
Make the "BuildRequires: java" unconditional and then close the bug?
Comment 8 Andrew Overholt 2005-10-21 14:34:27 EDT
I actually like things the way they are right now.  If anyone feels strongly
about changing it, go ahead and do it.  Closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.