Bug 160717 - Missing/Incorrect BuildRequires
Missing/Incorrect BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecj (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-16 16:26 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 20:03:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2005-06-16 16:26:57 EDT
During a test rebuild of ecj-2.1.3-5 in the mock builder, the following
problem manifests itself:

+ find -name '*.class' -or -name '*.properties' -or -name '*.rsc'
+ xargs jar cf ../../../ecj-2.1.3.jar
xargs: jar: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.45084 (%build)

The reason is, that the Required libgcj installs fastjar, but doesn't set up the
correct symlink with the alternatives system.
This is done by the java-$ver-compat package, which is not being installed.

According to nasrat the best way of dealing with this issue is dropping the
BuildRequires for gcc-java and libgcj and just setting a BuildRequire for
java-$ver-compat, or even better the virtual java-devel package which is
provided by the java-compat package. This will fix the alternatives problem and
pull in gcj and libgcj as well.

This bug is at least present in RHEL4, FC4, FC3 and current RawHide. Bugs were
filed for these releases as well.
Comment 1 Andreas Thienemann 2005-06-16 16:28:17 EDT
sorry. fc4 is not affected. again copy-n-waste... :(
Comment 2 Thomas Fitzsimmons 2005-06-17 10:56:09 EDT
Why not just change the xargs line to use fastjar?
Comment 3 Andreas Thienemann 2005-06-17 11:29:19 EDT
That might be a possibility, but would mean that the alternatives system is
bypassed.
Comment 4 Thomas Fitzsimmons 2006-02-03 20:03:10 EST
The standalone ecj package is obsolete and eclipse-ecj bootstraps fine.  Closing.

Note You need to log in before you can comment on or make changes to this bug.