This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 16072 - firewalld and ftp server incompatibility?
firewalld and ftp server incompatibility?
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-12 12:35 EDT by John William
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2000-08-12 12:35:36 EDT
I'm running RH6.2 and linuxconf 1.19r2. The machine has two ethernet 
interfaces, eth0 on the local network and eth1 connected to the Internet. 
I have installed wu-ftpd-2.6.0-14.6x and anonftp-3.0-3 to provide 
anonymous ftp service to the Internet.

Everything seems to be configured correctly as the internal machines can 
correctly access the Internet. Ftp from a machine on the internal network 
to the firewall works correctly. Ftp from the firewall to the firewall 
works correctly. However, whenever someone tried to connect from Internet, 
their ftp connection hangs for 3-4 minutes before giving a "Can't build 
data connection" error on the ftp client.

I have used the "internet firewall and masquerade" option under linuxconf 
to setup a basic masquerading firewall on the machine, and have enabled 
service 21/ftp under the TCP services section. I have confirmed that port 
21 is open (/sbin/ipchains -L -v). I know my service provider is not 
blocking port 21, since telneting to port 21 gives me the wu-ftp banner.
Comment 1 Brent Fox 2002-06-05 12:11:18 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:47:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.