Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 160745 - libicu-3.2-3 package requires libstdc++.so.5 not libstdc++.so.6 of FC4
libicu-3.2-3 package requires libstdc++.so.5 not libstdc++.so.6 of FC4
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-06-16 21:28 EDT by attard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-18 01:27:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description attard 2005-06-16 21:28:55 EDT
Description of problem:
Package requires libicu libraries, but libicu-3.2-3 package in extras requires
older version of libstdc++ libraries than available in Fedora Core 4.

Version-Release number of selected component (if applicable): 
mail-notification-1.1-3 and

How reproducible: Always

Steps to Reproduce:
1.rpm -Uvh mail-notification-1.1-3.i386.rpm libicu-3.2-3.i386.rpm
Actual results:
error: Failed dependencies:
        libstdc++.so.5 is needed by libicu-3.2-3.i386
        libstdc++.so.5(CXXABI_1.2) is needed by libicu-3.2-3.i386
        libstdc++.so.5(GLIBCPP_3.2) is needed by libicu-3.2-3.i386

Expected results:
Packages install successfully using libstdc++.so.6 available.

Additional info:
Note that libicu was not an available component to file a bug against, hence the
choice of mail-notification.
Comment 1 attard 2005-06-16 22:02:50 EDT
Note also that problem is solved by simply installing libstdc++ alongside the
newer one.
Comment 2 Michael Schwendt 2005-06-16 22:30:56 EDT
Your rpm command-line is missing "compat-libstdc++-33-3.2.3-47.fc4":

  $ rpm -q --whatprovides libstdc++.so.5

According to the libicu changelog, it was built with compat-gcc-32 as a
work-around for a bug and hence links against the older C++ library.
Comment 3 attard 2005-06-18 01:27:18 EDT
I should have checked the compat libraries - it is a cleaner fix than forcing
the install of the old libstdc++.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.