Bug 1607596 - MDS spams logs with unnecessary warnings about missing inodes during subtree migrations
Summary: MDS spams logs with unnecessary warnings about missing inodes during subtree ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
high
high
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1607680 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-23 19:42 UTC by Patrick Donnelly
Modified: 2018-08-13 20:58 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-12.2.4-39.el7cp Ubuntu: ceph_12.2.4-44redhat1
Doc Type: Bug Fix
Doc Text:
Previously, a normal result of subtree migration, missing inodes in the MDS cache, was broadcasted as a verbose debug log message. With this update, the debug log message has been reduced in verbosity, and the MDS debug logs at low setting will have fewer entries in normal operation.
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 25041 None None None 2018-07-23 19:42:57 UTC
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:28:24 UTC

Description Patrick Donnelly 2018-07-23 19:42:57 UTC
Description of problem:

e.g.

2018-07-03 03:10:20.042188 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x10014248370, dropping
2018-07-03 03:10:20.042191 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x1001424a92f, dropping
2018-07-03 03:10:20.042195 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x100142088f0, dropping
2018-07-03 03:10:20.042199 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x1001424bd21, dropping
2018-07-03 03:10:20.042201 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x10014250aa7, dropping
2018-07-03 03:10:20.042205 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x1001420892b, dropping
2018-07-03 03:10:20.042207 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x1001424804b, dropping
2018-07-03 03:10:20.042211 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x10014253b43, dropping
2018-07-03 03:10:20.042215 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x10014247786, dropping
2018-07-03 03:10:20.042221 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x10014246826, dropping
2018-07-03 03:10:20.042225 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x1001424908f, dropping
2018-07-03 03:10:20.042228 7fc717bf9700  1 mds.0.locker
handle_client_caps on unknown ino 0x100142496b9, dropping

Comment 3 Patrick Donnelly 2018-07-24 03:07:46 UTC
*** Bug 1607680 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-08-09 18:27:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.