Bug 1607601 - MDS should dump recent log messages in memory before respawn
Summary: MDS should dump recent log messages in memory before respawn
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1607683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-23 19:47 UTC by Patrick Donnelly
Modified: 2018-08-13 20:58 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-12.2.4-39.el7cp Ubuntu: ceph_12.2.4-44redhat1
Doc Type: Bug Fix
Doc Text:
The MDS will now dump recent log events in memory but not necessarily logged to the debug log file when the MDS respawns because the monitors have removed it from the MDSMap. This may occur when the MDS becomes stuck working on a long running operation. This is intended to help evaluate what the MDS was doing which resulted in the respawn.
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 25039 None None None 2018-07-23 19:47:47 UTC
Red Hat Bugzilla 1601138 None None None Never
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:28:24 UTC

Internal Links: 1601138

Description Patrick Donnelly 2018-07-23 19:47:48 UTC
Description of problem:

When the MDS respawns because it has been removed from the MDSMap, it should dump recent events to the log (ones stored in memory but not logged to a file, in particular) so that the logs can be useful for diagnostic purposes.

Comment 3 Patrick Donnelly 2018-07-24 03:06:54 UTC
*** Bug 1607683 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-08-09 18:27:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.