Bug 160784 - FC4: Installers hangs (freezes) when starting x-server, Problem with Matrox Millennium G400
FC4: Installers hangs (freezes) when starting x-server, Problem with Matrox ...
Status: CLOSED DUPLICATE of bug 163331
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-17 05:26 EDT by Silvio Schneider
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 07:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg configfile (2.67 KB, text/plain)
2005-06-27 02:42 EDT, Silvio Schneider
no flags Details
xorg logfile from /var/log (8.58 KB, text/plain)
2005-06-27 02:43 EDT, Silvio Schneider
no flags Details

  None (edit)
Description Silvio Schneider 2005-06-17 05:26:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I wantet to install FC 4 on my machine, but the installer hangs.

After choosing the graphical installer anaconda is starting to probe the machine.
Graphic card (Matrox Milenium) was successfully dected.
Monitor is shown as "unknown" !  (it is a Sony Multiscan 20 SE)
When the installer tries to start the X-Server it freezes
with a blue screen :-(

Version-Release number of selected component (if applicable):
FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot PC with CD 1
2. start graphical installer
  

Actual Results:  installer freezes with a blue screen and a dark blue curser(not blinking) on top left

Expected Results:  start the x-server,
show the graphical installer

Additional info:

FC 2 is installed and running nicely on this machine.
Please contact me if you need more information about the hardware.
Comment 1 Jeremy Katz 2005-06-17 11:43:29 EDT
Does booting with 'linux nofb' help?
Comment 2 Silvio Schneider 2005-06-20 03:16:16 EDT
No, not really.
After probing for videcoard, monitor and mouse. It freezes at the same position.
:-( This time it freezes with a black screen and a small green border.
I can see a grey letter on the lower right. Only half of the letter is visible.
It is problably a "B" or a "H".

So far my FC2 stays installed. Any other ideas, what to do next? 
Comment 3 Silvio Schneider 2005-06-24 06:28:19 EDT
Hi outthere,

Do you need the xorg logfile? I haven't seen anything special in it.
I can post it here if you want.

Regards
Suvi
Comment 4 Mike A. Harris 2005-06-24 12:32:31 EDT
The X server log file and config file are mandatorily required for all
X bug reports.  In addition to providing error messages and warnings, the
log file provides complete details of the hardware in the system, PCI config
space details, and many other details both about the hardware and various
aspects of the X server starting up, probing things, etc. which are
informational, and often instrumental in diagnosing problems.

Always attach your X server log and config file to bug reports, if it turns
out to not be useful, we can decide that, however if it is missing, then
we dont have the option of looking at it, and wont investigate a bug until
the files are attached, so always attaching them makes things happen faster.

Thanks in advance.

P.S.  This looks like a duplicate of bug #161242.  Please review that bug
and test the workaround mentioned in it and let us know if the problem
goes away.  Note that you'll need to do a text mode install first, and
then perform this testing in runlevel 3 after install.

Hope that helps.
Comment 5 Silvio Schneider 2005-06-27 02:42:11 EDT
Created attachment 116003 [details]
xorg configfile

xorg configfile attached
Comment 6 Silvio Schneider 2005-06-27 02:43:20 EDT
Created attachment 116004 [details]
xorg logfile from /var/log

xorg logfile attached
Comment 7 Silvio Schneider 2005-06-27 03:01:10 EDT
Hi Mike,

I did made the text mode installation. I have started the kernel 
with -s to reach singleusermode. So I can start the runlevels one
by one. As you can see I have attached the logs for you.

I have replaced the libvgahw.a with the one from 
ftp://people.redhat.com/mharris/libvgahw.a

It didn't help. When I start FC4 now it is ending up in a totaly
black screen. After about 5 seconds the machine reboots by itself.

My next step is to install the xorg package from FC3


Comment 8 Silvio Schneider 2005-06-27 03:34:57 EDT
I am stuck allready with the downgrading xorg to FC3

I took some rpms from
http://mirror.switch.ch/ftp/mirror/fedora/linux/core/3/i386/os/Fedora/RPMS/

rpm -i xorg-x11-libs-6.8.1-12.i386.rpm --force

didn't help. Still the black screen, but no reboot this time

and

[root@myPC ~]# rpm -i xorg-x11-6.8.1-12.i386.rpm --force
warning: xorg-x11-6.8.1-12.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        xorg-x11-xfs = 6.8.1-12 is needed by xorg-x11-6.8.1-12.i386

doesn't wont to be downgraded.

What rpms do I need and how should I install them ?

Please help out.

Comment 9 Silvio Schneider 2005-06-27 04:06:37 EDT
stupid me!
rpm -i xorg-x11-xfs-6.8.1-12.i386.rpm --force
rpm -i xorg-x11-6.8.1-12.i386.rpm --force
was enough to make it work.

Wow this FC4 with Gnome 2.10 is fast.
Almost like a rocket comparing to FC3.
Comment 10 Olivier Baudron 2005-07-30 09:35:09 EDT
Can you give the output of: lspci -v
This report is certainly a duplicate of bug #163331
Please, try xorg-x11-6.8.2-44, it should fix your problem.
Comment 11 Silvio Schneider 2005-08-17 10:00:12 EDT
no problemo:

[root@PegasusTest ~]# lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4
)
        Flags: bus master, medium devsel, latency 0
        Memory at d0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: d4000000-d7ffffff
        Prefetchable memory behind bridge: d8000000-d9ffffff
        Capabilities: [80] Power Management version 2

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 21)
        Subsystem: VIA Technologies, Inc. VT82C686/A PCI to ISA Bridge
        Flags: bus master, stepping, medium devsel, latency 0

00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C P
IPC Bus Master IDE (rev 10) (prog-if 8a [Master SecP PriP])
        Flags: bus master, medium devsel, latency 32
        I/O ports at d000 [size=16]
        Capabilities: [c0] Power Management version 2

00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (r
ev 10) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at d400 [size=32]
        Capabilities: [80] Power Management version 2

00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (r
ev 10) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2

00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
        Flags: medium devsel, IRQ 5
        Capabilities: [68] Power Management version 2

00:08.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter)
 Ethernet Controller
        Subsystem: Netgear: Unknown device f331
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at dc00 [size=256]
        Memory at db000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2

00:09.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
        Subsystem: 3Com Corporation 3C905C-TX Fast Etherlink for PC Management NIC
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at e000 [size=128]
        Memory at db001000 (32-bit, non-prefetchable) [size=128]
        Capabilities: [dc] Power Management version 2

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04) (pro
g-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc. Millennium G400 16Mb SGRAM
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at d8000000 (32-bit, prefetchable) [size=32M]
        Memory at d4000000 (32-bit, non-prefetchable) [size=16K]
        Memory at d5000000 (32-bit, non-prefetchable) [size=8M]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0

[root@PegasusTest ~]#
Comment 12 Olivier Baudron 2005-08-17 10:52:31 EDT
Ok, now can you upgrade to xorg-x11-6.8.2-45 with the command:
$ yum --enable=development -y update xorg-x11
and tell us if it fixes your problem.
Comment 13 Silvio Schneider 2005-08-31 05:40:16 EDT
I have used yum to make a 38 Mbyte update to xorg-x11.6.8.2-45.
This updated the glibx library as well.

To test I made a complete restart of the pc. The Linux-Box ist booting fine and
Gnome is showing up. Unfortunalty SELINUX crashes during the shutdown, but
doesn't bother me.

I think there are now to x11 version installed on my system. How can I check this?
How can I check wich x11 version is loaded?
Comment 14 Silvio Schneider 2005-08-31 05:42:18 EDT
Enchaing the Title of this bug with 
 Problem with Matrox Millennium G400
Comment 15 Olivier Baudron 2005-08-31 07:59:22 EDT
> How can I check wich x11 version is loaded?

$ rpm -q xorg-x11
Comment 16 Olivier Baudron 2005-08-31 07:59:56 EDT

*** This bug has been marked as a duplicate of 163331 ***
Comment 17 Silvio Schneider 2005-09-01 02:50:31 EDT
#rpm -q xorg-x11
xorg-x11-6.8.2-45

ok. Great this is correct.
Would be nice to release a fedora core 4.1 because the installation
is quite complicated with this graphic card.
Comment 18 Mike A. Harris 2005-09-14 04:59:17 EDT
Fedora Core releases do not get respun by Red Hat, however the Fedora
community, and end users are free to take Fedora and update the rpms,
and roll new CD images for themselves or for others if they like.
The process isn't trivial mind you, but it is doable.  Join
anaconda-devel-list@redhat.com if you require assistance creating your
own updated CD/DVD images.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.