Bug 160787 - no user entry in /etc/passwd after useradd
no user entry in /etc/passwd after useradd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-17 05:52 EDT by Daniel Hammer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 06:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hammer 2005-06-17 05:52:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
If a user is added via "useradd foo" a directory is created but there is no new entry line in /etc/passwd. Consequently "passwd foo" will fail with the error message that user foo does not exist.
The gui tool system-config-users does create the users correctly and passwords are  also given correctly.
Tried to switch off selinux, first to permissive and the to disabled but this does not change anything.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.7-9

How reproducible:
Always

Steps to Reproduce:
1. login as root
2. type useradd foo and then passwd foo
  

Actual Results:  1. get an error message that user foo does not exist 
2. see that /home/foo was nevertheless created

Expected Results:  the user should be created correctly.

Additional info:
Comment 1 Peter Vrabec 2005-06-28 06:07:18 EDT
I can't reproduce it.

# useradd foo
# cat /etc/passwd | grep foo
foo:x:501:501::/home/foo:/bin/bash
# rpm -q shadow-utils
shadow-utils-4.0.7-9
Comment 2 Daniel Hammer 2005-06-28 13:28:19 EDT
Ok, now it works for me too, but I have installed a whole bunch of updates now.
On a fresh install it didn't work.

Note You need to log in before you can comment on or make changes to this bug.