Bug 16079 - cannot install GUI on Compaq 12XL125
cannot install GUI on Compaq 12XL125
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-12 17:05 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 11:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-12 17:05:27 EDT
I have a Compaq 12XL125 laptop (uses the CyberBlade/i7 Trident chipset).  I
cannot install in GUI mode because the display is corrupted.  It appears to
be detecting the correct chipset, Xserver, etc., so the problem is
presumably one of incorrect modelines for the LCD?

I already have Linux installed on this laptop, and can provide a working
XF86Config from XFree86 3.3.6 if that would be helpful.
Comment 1 Red Hat Bugzilla 2000-08-14 12:05:34 EDT
what resolution are you trying?  Have you tried other resolutions?  What does
the corruption look like?
Comment 2 Red Hat Bugzilla 2000-08-14 12:17:14 EDT
I haven't tried any resolutions, because I don't get far enough to do that.  It
gets to the "running /sbin/anaconda - may take a while" (or whatever it says),
starts up X, and I'm instantly dead at that point -- the screen is impossible to
see to continue further.

The screen corruption is that solid sheet of bright white - mottled grey that
laptop LCDs do when you drive them at too high a refresh (well, at least that's
the only time I've ever done it otherwise).
Comment 3 Red Hat Bugzilla 2000-08-17 11:24:45 EDT
Does your laptop support running in 640x480?

If not, you can run the installer in text mode by typing

linux text

at the install boot prompt.  It should allow you to then setup X at the support
resolution on your laptop.

If this doesn't work please reopen this bug.
Comment 4 Red Hat Bugzilla 2000-08-19 11:42:52 EDT
I finally managed to get the laptop to install in text mode.  It failed to
configure X.  Running Xconfigurator manually got X configured for 3.3.6, but not
for 4.0.1.  The major problem both with the install and with the autoconfigure /
Xconfigurator problems is probably that with XFree 3.3.6, this chipset uses the
SVGA driver, but with XFree 4, it uses the Trident driver....
Comment 5 Red Hat Bugzilla 2000-08-21 15:54:09 EDT
Does it work well with XFree86 4.0? There is a new Xconfigurator at
http://people.redhat.com/teg/xc/ - please try that with the "--preferxf4"
switch.
Comment 6 Red Hat Bugzilla 2000-10-24 11:25:23 EDT
Please reopen this bug if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.