Bug 1607981 - No extlinux.conf entry added for new kernel installs on armhfp
Summary: No extlinux.conf entry added for new kernel installs on armhfp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: rawhide
Hardware: armhfp
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2018-07-24 16:30 UTC by Paul Whalen
Modified: 2018-08-02 17:47 UTC (History)
3 users (show)

Fixed In Version: grubby-8.40-17.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-02 17:47:19 UTC


Attachments (Terms of Use)

Description Paul Whalen 2018-07-24 16:30:35 UTC
Description of problem:

After installing a new kernel on armhfp, rebooting there is no new entry added for the new kernel, nor is the removed kernel removed from extlinux.conf. 

This appears to be the result of the Boot Loader Specification change in F29.
https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault

No extlinux support is listed.

How reproducible:
Everytime

Comment 1 Javier Martinez Canillas 2018-07-24 17:52:28 UTC
(In reply to Paul Whalen from comment #0)
> Description of problem:
> 
> After installing a new kernel on armhfp, rebooting there is no new entry
> added for the new kernel, nor is the removed kernel removed from
> extlinux.conf. 
> 
> This appears to be the result of the Boot Loader Specification change in F29.
> https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault
> 
> No extlinux support is listed.
> 
> How reproducible:
> Everytime

The problem was that grubby didn't have the executable bit set so new-kernel-pkg just existed without calling grubby.

This should be fixed by https://koji.fedoraproject.org/koji/taskinfo?taskID=28573349

Comment 2 Paul Whalen 2018-07-24 21:15:15 UTC
Output with grubby-8.40-16.fc29:

..
  Running scriptlet: kernel-lpae-core-4.18.0-0.rc6.git0.1.fc29.armv7hl                                                                                                                    3/3 
/sbin/grubby: line 5: /usr/libexec/grubby: Is a directory
/sbin/grubby: line 5: exec: /usr/libexec/grubby: cannot execute: Is a directory
/sbin/grubby: line 5: /usr/libexec/grubby: Is a directory
/sbin/grubby: line 5: exec: /usr/libexec/grubby: cannot execute: Is a directory
  Running scriptlet: kernel-lpae-4.18.0-0.rc6.git0.1.fc29.armv7hl                                                                                                                         3/3 
  Verifying        : kernel-lpae-4.18.0-0.rc6.git0.1.fc29.armv7hl                                                                                                                         1/3 
  Verifying        : kernel-lpae-core-4.18.0-0.rc6.git0.1.fc29.armv7hl                                                                                                                    2/3 
  Verifying        : kernel-lpae-modules-4.18.0-0.rc6.git0.1.fc29.armv7hl

Comment 3 Javier Martinez Canillas 2018-07-25 07:42:59 UTC
(In reply to Paul Whalen from comment #2)
> Output with grubby-8.40-16.fc29:
> 
> ..
>   Running scriptlet: kernel-lpae-core-4.18.0-0.rc6.git0.1.fc29.armv7hl      
> 3/3 
> /sbin/grubby: line 5: /usr/libexec/grubby: Is a directory
> /sbin/grubby: line 5: exec: /usr/libexec/grubby: cannot execute: Is a
> directory
> /sbin/grubby: line 5: /usr/libexec/grubby: Is a directory
> /sbin/grubby: line 5: exec: /usr/libexec/grubby: cannot execute: Is a
> directory
>   Running scriptlet: kernel-lpae-4.18.0-0.rc6.git0.1.fc29.armv7hl           
> 3/3 
>   Verifying        : kernel-lpae-4.18.0-0.rc6.git0.1.fc29.armv7hl           
> 1/3 
>   Verifying        : kernel-lpae-core-4.18.0-0.rc6.git0.1.fc29.armv7hl      
> 2/3 
>   Verifying        : kernel-lpae-modules-4.18.0-0.rc6.git0.1.fc29.armv7hl

Right, sorry for missing that. Should be fixed in grubby-8.40-17.fc29.

Comment 4 Paul Whalen 2018-07-25 13:43:00 UTC
Looks good with grubby-8.40-17.fc29, thanks Javier!


Note You need to log in before you can comment on or make changes to this bug.