Bug 160800 - a second language support not easy as FC3
a second language support not easy as FC3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-17 08:23 EDT by Nikos Charonitakis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-17 11:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2005-06-17 08:23:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Previews FC installers used additional language support screen and system default language options. Now in FC4 user has to select custom packages option and then add support to a second language.
So when users select workstation installation for example cant see easily where to add a second language.
Also supposed that finally users find and check the box for a second language there is no way to make this language default for the system through system-config -language tool. It presents only one language to choose...
So at last they have to edit /etc/sysconfig/i18n to add and make default their language preference.
Certainly not an obvious way and a step back from FC3.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install FC4
2.want a second language support 
3.make this language default for the system
  

Actual Results:  difficult configuration for new users

Expected Results:  Fc3 way was clearer

Additional info:
Comment 1 Nikos Charonitakis 2005-06-17 08:25:32 EDT
i mean previous FC installers...
Comment 2 Dimitri Papadopoulos 2005-06-17 09:25:00 EDT
*** Bug 160806 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2005-06-17 11:45:25 EDT
It's actually *easier* to add languages now.  Users get the option to add them
post-install as well.  The only reason it seems "harder" is its different.
Comment 4 Nikos Charonitakis 2005-06-17 14:44:29 EDT
ok.
then drop the "easy to install" issue.

Can you please tell us how to set any additional language as default for the
system (during or after installation) and if it is easier than before?
Comment 5 Dimitri Papadopoulos 2005-06-20 05:04:26 EDT
Exatcly. As described in bug #160806, I've followed the instructions in the
"Fedora Core 4 Installation Guide":
http://fedora.redhat.com/docs/fedora-install-guide-en/fc4/ch-installer-locale.html#sn-installer-language
http://fedora.redhat.com/docs/fedora-install-guide-en/fc4/sn-lang-packages.html
This does install additional language packages, but it doesn't add support for
other default system languages as was the case in FC3:
	# cat /etc/sysconfig/i18n
	LANG="en_US.UTF-8"
	SYSFONT="latarcyrheb-sun16"
	SUPPORTED="en_US.UTF-8:en_US:en"
	# 

As it is system-config-language is useless.
Comment 6 Nikos Charonitakis 2005-06-20 09:39:56 EDT
reopen or open a new bug report?
Maybe i was not clear enough in my initial report.
So the bug is that installer does not put the needed text in /etc/sysconfig/i18n
when a user selects to  install additional languages.
for example:

LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en"

should be something like that:


LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="el_GR.UTF-8:el_GR:el:en_US.UTF-8:en_US:en"

(for Greek language support) and then system-config-language will be usable again.
Comment 7 Chris Lumens 2005-06-28 15:59:35 EDT
The real problem here is that wasn't any way for the supported languages list to
get updated when new language support packages are selected on that screen.  We
really don't need to maintain a supported list for any good reason anyway. 
s-c-language should be able to do the right thing in that case.  Fixed in CVS by
removing all sorts of complicated and unnecessary langsupport code.

Note You need to log in before you can comment on or make changes to this bug.