Bug 1608260 - [WhnpxDH8] Learn more link on Expand PVC page should point to dev_guide/expanding_persistent_volumes.html
Summary: [WhnpxDH8] Learn more link on Expand PVC page should point to dev_guide/expan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.11.z
Assignee: Ankush Behl
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-25 08:17 UTC by Yadan Pei
Modified: 2019-06-26 09:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 09:07:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:07:59 UTC

Description Yadan Pei 2018-07-25 08:17:30 UTC
Description of problem:
Learn more link on Expand PVC page better point to dev_guide/expanding_persistent_volumes.html rather than dev_guide/persistent_volumes.html

Version-Release number of selected component (if applicable):
openshift v3.11.0-0.9.0
OpenShift Web Console:    v3.11.0-0.9.0 

How reproducible:
Always

Steps to Reproduce:
1.Create a StorageClass with allowVolumeExpansion set to true
$ cat storageclass.yaml << EOF
apiVersion: storage.k8s.io/v1beta1
kind: StorageClass
metadata:
  name: slow
  annotations:
    storageclass.beta.kubernetes.io/is-default-class: "false"
provisioner: kubernetes.io/gce-pd
parameters:
  type: pd-ssd
allowVolumeExpansion: true
EOF
$ oc create -f storageclass.yaml
2.Create PVC using this storageclass
3.When PVC is bound, go to PVC page, Actions -> Expand PVC

Actual results:
3. Learn more link points to dev_guide/persistent_volumes.html

Expected results:
3. The link is better to be dev_guide/expanding_persistent_volumes.html where user could get info about expanding pvc

Additional info:

Comment 1 Yadan Pei 2018-08-28 01:38:25 UTC
This also fixed in OpenShift Web Console:    v3.11.0-0.24.0 

Move to VERIFIED directly

Comment 3 errata-xmlrpc 2019-06-26 09:07:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605


Note You need to log in before you can comment on or make changes to this bug.