Bug 160832 - Evolution Setup Assistance crashes when attempting to select server type from Receiving Mail screen
Evolution Setup Assistance crashes when attempting to select server type from...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 162074 (view as bug list)
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-06-17 14:28 EDT by James Laska
Modified: 2013-09-02 02:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: libgal2-2.4.3-1.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 13:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated evolution backtrace (4.38 KB, text/plain)
2005-06-20 11:52 EDT, James Laska
no flags Details
backtrace from evolution-2.2.2-11.fc5 (5.96 KB, text/plain)
2005-06-29 11:46 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2005-06-17 14:28:52 EDT
RPM: evolution-2.2.2-8

Evolution is crashing while attempting to select my imap server in the
first-time setup assistant.  This is repeatable (even after purging
~/.evolution,  ~/.gconf/apps/evolution, and ~/.gnome2_private/Evolution).  It
appears to not matter what server type I select, all options will produce the
crash.  Please advise if there is any additional debuging information I can provide.

Steps to reproduce:
 1) Start evolution for the first time
 2) Enter name/email, and select next
 3) Select any option under the "Server Type" 

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208691008 (LWP 4553)]
[New Thread -1213158480 (LWP 4570)]
0x00695402 in ?? ()
#0  0x00695402 in ?? ()
#1  0x00bdcfbb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x04f89080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x080634d5 in segv_redirect (sig=11) at main.c:428
#4  <signal handler called>
#5  0x001866de in gtk_combo_box_set_active_iter ()
   from /usr/lib/libgtk-x11-2.0.so.0
#6  0x007f7017 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#7  0x007ea475 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8  0x007fa176 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#9  0x007fbbc8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x007fbf19 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#11 0x002e78bd in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x0021a01a in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#13 0x0021a2ed in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#14 0x002117fd in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x0020c352 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#16 0x007e9f8b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#17 0x007ea475 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#18 0x007fa302 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#19 0x007fb925 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#20 0x007fbf19 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#21 0x002e7ac3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x0020aab7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x0020aef4 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x00545d6e in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#25 0x00af4f3e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0x00af7f46 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#27 0x00af8233 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#28 0x0020a1b5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x009b7efc in startup_wizard (ep=0x9081178, target=0x90e2df0)
    at startup-wizard.c:268
#30 0x055509be in epl_invoke (ep=0x9081178, name=0x9052618 "startup_wizard", 
    data=0xaaaaaaaa) at e-plugin.c:790
#31 0x0554feed in e_plugin_invoke (ep=0x9081178, 
    name=0x91240a8 "\200ø\023\t\023", data=0x91240a8) at e-plugin.c:579
#32 0x0554af9c in emph_event_handle (ee=0xaaaaaaaa, item=0xaaaaaaaa, 
    data=0x9054630) at e-event.c:406
#33 0x0554ae43 in e_event_emit (emp=0x904c5a0, id=0x80673d4 "upgrade.done", 
    target=0x90e2df0) at e-event.c:295
#34 0x08060e15 in e_shell_attempt_upgrade (shell=0xaaaaaaaa) at e-shell.c:876
#35 0x0806155f in e_shell_construct (shell=0x90d5620, 
    iid=0x8067750 "OAFIID:GNOME_Evolution_Shell:2.2", 
    startup_line_mode=E_SHELL_STARTUP_LINE_MODE_CONFIG) at e-shell.c:653
#36 0x0806169e in e_shell_new (startup_line_mode=2863311530, 
    construct_result_return=0xbf86da28) at e-shell.c:700
#37 0x08063188 in idle_cb (data=0x0) at main.c:352
#38 0x00af71a0 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#39 0x00af4f3e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x00af7f46 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#41 0x00af8233 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#42 0x050f5625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#43 0x08063930 in main (argc=152191144, argv=0xbf86de84) at main.c:610

Thread 2 (Thread -1213158480 (LWP 4570)):
#0  0x00695402 in ?? ()
No symbol table info available.
#1  0x00bd97a6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x052773c7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x05277abd in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00bd7b80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00ebfdee in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208691008 (LWP 4553)):
#0  0x00695402 in ?? ()
No symbol table info available.
#1  0x00bdcfbb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x04f89080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x080634d5 in segv_redirect (sig=11) at main.c:428
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x001866de in gtk_combo_box_set_active_iter ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#6  0x007f7017 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#7  0x007ea475 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#8  0x007fa176 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x007fbbc8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x007fbf19 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x002e78bd in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#12 0x0021a01a in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x0021a2ed in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0x002117fd in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#15 0x0020c352 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#16 0x007e9f8b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#17 0x007ea475 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#18 0x007fa302 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#19 0x007fb925 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#20 0x007fbf19 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#21 0x002e7ac3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#22 0x0020aab7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#23 0x0020aef4 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#24 0x00545d6e in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#25 0x00af4f3e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#26 0x00af7f46 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#27 0x00af8233 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#28 0x0020a1b5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#29 0x009b7efc in startup_wizard (ep=0x9081178, target=0x90e2df0)
    at startup-wizard.c:268
	client =
Comment 1 James Laska 2005-06-20 11:52:12 EDT
Created attachment 115700 [details]
Updated evolution backtrace

Updated backtrace from evolution with the following debuginfo packages
installed:

evolution-data-server-debuginfo-1.2.2-3
gail-debuginfo-1.8.3-2
GConf2-debuginfo-2.10.0-4
glibc-debuginfo-2.3.5-10
glibc-debuginfo-common-2.3.5-10
libgnome-debuginfo-2.10.0-3
libgnomeui-debuginfo-2.10.0-1
pango-debuginfo-1.8.1-2
Comment 2 Dave Malcolm 2005-06-20 17:04:56 EDT
Works for me with the Account Editor, creating a new account, though that's not
in the first-time wizard; will try with a new test user
Comment 3 Dave Malcolm 2005-06-20 17:21:59 EDT
Works for me with evolution-2.2.2-8, doing it in the first-time wizard for a
fresh account.
Comment 4 James Laska 2005-06-23 08:20:56 EDT
- Unable to reproduce with a fresh FC-4 install
- Updating system to current devel packages and the problem resurfaces
  > crash when selecting remote mail server type
  > crash when choosing to create a remote calendar (local works)
  > crash when choosing to create a remote todo list (local works)

Something in the changeset is causing the failure.  My first thought is that it
may be a dependent library (libgnome or libbonobo).  A comparison between the
packages provided in FC-4 and 2005-06-22 devel can be found
http://people.redhat.com/jlaska/fc4_vs_2005-06-22.diff .  You can see from the
side-by-side diff that niether libgnome or libbonobo has changed.  Any thoughts?
 The failure cases noted above appear to all be related to code that may be
looking out on the web (remote todo/caledar/mail).

Comment 5 James Laska 2005-06-23 09:07:24 EDT
$ strace -f -o http://people.redhat.com/jlaska/evolution.strace /usr/bin/evolution
Comment 6 James Laska 2005-06-29 11:46:43 EDT
Created attachment 116131 [details]
backtrace from evolution-2.2.2-11.fc5

I continue to have problems with rawhide evolution (yeah I know it's rawhide
;)).  I am attaching a backtrace when running evolution-2.2.2-11.fc5.  The last
component I had opened was the calendar so I believe evolution is failing when
attempting to load up my calendar.  

These all seem related, however please advise if you feel these are seperate
issues.
Comment 7 James Laska 2005-06-29 11:48:15 EDT
I continue to encounter the backtrace attachment#116131 [details] when running:

  $ evolution -c calendar

But am able to work around it using:
  $ evolution -c mail
Comment 8 Dave Malcolm 2005-06-29 12:29:25 EDT
Might be a dup of http://bugzilla.gnome.org/show_bug.cgi?id=304915 (which I
can't access right now as gnome bugzilla is down) which was fixed in gal-2.4.3;
I'll push an update out in any case.
Comment 9 Dave Malcolm 2005-06-29 14:47:53 EDT
*** Bug 162074 has been marked as a duplicate of this bug. ***
Comment 10 Jukka Ketelaars 2005-07-05 17:05:26 EDT
As libgal2-2.4.3 does not seem to be in rawhide yet, I installed the build from
nrpms.net (http://www.nrpms.net/Packages/fedora-4-i386/production/libgal2.html).
This fixed the problem.
Comment 11 Daniel Malmgren 2005-07-06 09:12:22 EDT
Any chance we'll be seeing gal 2.4.3 in rawhide soon?
Comment 12 James Laska 2005-07-07 07:52:49 EDT
Using the rpms built with the 2.4.3 ftp.gnome.org sources:
   
   http://people.redhat.com/jlaska/160832/

I no longer crash when attempting to click on my calendar, task list, or
contacts.  However, I still cannot create a new remote calendar, task list, or
contact list.  That will continue to produce a crash (see
http://people.redhat.com/jlaska/160832/evolution.backtrace).  Perhaps this is a
different bug?
Comment 13 Seth Nickell 2005-07-26 14:31:36 EDT
I get this too, on a fresh install of Rawhide.
Comment 14 Ryan Skadberg 2005-07-26 18:29:32 EDT
Updating GAL from nrpms fixed 162074 for me, which was marked as a dupe of this.
Comment 15 Dave Malcolm 2005-08-18 18:45:59 EDT
In rawhide, Evolution is now at 2.3.7, and libgal2 has been removed (all of the
code is now in the evolution package directly)

I released a test update of libgal2-2.4.3-1.fc4 in June; somehow this never got
pushed as a full update.  Will do this shortly.
Comment 16 Dave Malcolm 2005-08-22 13:49:31 EDT
libgal2-2.4.3-1.fc4 is now available as an update

Note You need to log in before you can comment on or make changes to this bug.