Bug 1608421 - avc: denied { map } for pid=8885 comm="eu-unstrip" path="/tmp/tmp.jEtebk00cB/suidedexecutable" dev="dm-0"
Summary: avc: denied { map } for pid=8885 comm="eu-unstrip" path="/tmp/tmp.jEtebk00...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-25 13:45 UTC by Martin Kyral
Modified: 2018-10-30 10:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1642305 (view as bug list)
Environment:
Last Closed: 2018-10-30 10:07:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:08:09 UTC

Description Martin Kyral 2018-07-25 13:45:27 UTC
Description of problem:
ABRT tests are plagued with this AVC:

time->Tue Jul 24 10:17:40 2018
type=PROCTITLE msg=audit(1532441860.628:4211): proctitle=65752D756E7374726970002D2D636F72653D2E2F636F726564756D70002D6E
type=MMAP msg=audit(1532441860.628:4211): fd=14 flags=0x2
type=SYSCALL msg=audit(1532441860.628:4211): arch=c0000015 syscall=90 success=no exit=-13 a0=0 a1=11248 a2=3 a3=2 items=0 ppid=8884 pid=8885 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="eu-unstrip" exe="/usr/bin/eu-unstrip" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1532441860.628:4211): avc:  denied  { map } for  pid=8885 comm="eu-unstrip" path="/tmp/tmp.jEtebk00cB/suidedexecutable" dev="dm-0" ino=100788082 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0




Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-207.el7.noarch

How reproducible:


Steps to Reproduce:
1. run the linked test case
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 errata-xmlrpc 2018-10-30 10:07:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.