Bug 16085 - rpm seg faults
rpm seg faults
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
http://www.bmwsearch.net
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-12 19:26 EDT by Wm.L.Scheding
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-12 19:26:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wm.L.Scheding 2000-08-12 19:26:29 EDT
when I try to install the pam package it says:

[root@hippi todo]# rpm -Fvh ../rh62updates/rpm-3.0.5-9.6x.i386.rpm 
[root@hippi todo]# rpm -Fvh pam-0.72-20.i386.rpm 
Segmentation fault
[root@hippi todo]# rpm -v
RPM version 3.0.5
Copyright (C) 1998 - Red Hat Software

I think I got the latest pam installed OK; but I was being
sure. I just thought I would mention it.

I'm running 6.2 (Professional).
my box is a dual pentium w/ apache & pretty stock everything else.
recent upgrade from 6.1 CD.

Hope this helps

wls
Comment 1 Jeff Johnson 2000-08-24 12:34:11 EDT
This works for me. That usually means that the seg fault is due to bad data in
the rpm database
that will be repaire if you do
	rpm --rebuilddb
If that doesn't fix the problem, please try installing as
	strace -o /tmp/xxx rpm -Fvv pam-0.72-20.i386.rpm
and reopen this bug with the output /tmp/xxx as attachment.

Note You need to log in before you can comment on or make changes to this bug.