Bug 1608512 - cluster.server-quorum-type help text is missing possible settings
Summary: cluster.server-quorum-type help text is missing possible settings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Shwetha K Acharya
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-25 16:45 UTC by Joe Julian
Modified: 2019-03-25 16:30 UTC (History)
4 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:30:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21644 0 None Open cli: cluster.server-quorum-type help text is missing 2018-11-16 03:21:38 UTC

Description Joe Julian 2018-07-25 16:45:34 UTC
Description of problem:
cluster.server-quorum-type help text is missing the possible settings in `gluster volume set help`

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. gluster volume set help | grep -A2 cluster.server-quorum-type

Actual results:
Option: cluster.server-quorum-type
Default Value: (null)
Description: This feature is on the server-side i.e. in glusterd. Whenever the glusterd on a machine observes that the quorum is not met, it brings down the bricks to prevent data split-brains. When the network connections are brought back up and the quorum is restored the bricks in the volume are brought back up.


Expected results:
Somewhere it should say what the possible values are and the default should be one of those (null doesn't really tell us what the default does).

Additional info:

Comment 1 Atin Mukherjee 2018-07-28 16:35:50 UTC
Sanju - could you check this?

Comment 2 Shwetha K Acharya 2018-11-03 06:25:31 UTC
According to the documentation https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.4/html/administration_guide/volume_option_table,
the cluster.server-quorum-type value is of datatype string and it can be either none or server. The result is in accordance with the documentation.

May be not a bug?

Comment 3 Atin Mukherjee 2018-11-08 12:06:19 UTC
Please don't mix match upstream vs downstream. The one what you're referring at is a downstream admin guide for RHGS.

gluster volume set help | grep -A2 cluster.server-quorum-type doesn't list down anything in upstream which means it doesn't provide the description of this option which is the bug we need to address.

Comment 4 Worker Ant 2018-11-14 11:14:45 UTC
REVIEW: https://review.gluster.org/21644 (cli: cluster.server-quorum-type help text is missing) posted (#1) for review on master by Shwetha K Acharya

Comment 5 Worker Ant 2018-11-16 03:21:37 UTC
REVIEW: https://review.gluster.org/21644 (cli: cluster.server-quorum-type help text is missing) posted (#2) for review on master by Amar Tumballi

Comment 6 Shyamsundar 2019-03-25 16:30:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.