Bug 1608545 - avc failure reported while testing oracleasm
Summary: avc failure reported while testing oracleasm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-25 18:56 UTC by Daniel Yeisley
Modified: 2018-10-30 10:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:07:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:08:09 UTC

Description Daniel Yeisley 2018-07-25 18:56:35 UTC
Description of problem:
AVC errors reported while testing Oracle Grid with oracleasm on two node cluster.


Info: Searching AVC errors produced since 1532538435.36 (Wed Jul 25 13:07:15 2018)
Searching logs...
Running '/usr/bin/env LC_ALL=en_US.UTF-8 /sbin/ausearch -m AVC -m USER_AVC -m SELINUX_ERR -ts 07/25/2018 13:07:15 < /dev/null >/mnt/testarea/tmp.rhts-db-submit-result.s7rXMz 2>&1'
----
time->Wed Jul 25 13:08:31 2018
type=PROCTITLE msg=audit(1532538511.864:975): proctitle="oracleasm-reload-partitions"
type=SYSCALL msg=audit(1532538511.864:975): arch=c000003e syscall=16 success=yes exit=0 a0=4 a1=125f a2=0 a3=193 items=0 ppid=33679 pid=33684 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="oracleasm-reloa" exe="/usr/lib/oracleasm/oracleasm-reload-partitions" subj=system_u:system_r:oracleasm_t:s0 key=(null)
type=AVC msg=audit(1532538511.864:975): avc:  denied  { sys_admin } for  pid=33684 comm="oracleasm-reloa" capability=21  scontext=system_u:system_r:oracleasm_t:s0 tcontext=system_u:system_r:oracleasm_t:s0 tclass=capability permissive=1
Fail: AVC messages found.
Checking for errors...
Using stronger AVC checks.
	Define empty RHTS_OPTION_STRONGER_AVC parameter if this causes any problems.
Running 'cat /mnt/testarea/tmp.rhts-db-submit-result.s7rXMz | /sbin/ausearch -m AVC -m SELINUX_ERR'
Fail: AVC messages found.
Running 'cat %s | /sbin/ausearch -m USER_AVC >/mnt/testarea/tmp.rhts-db-submit-result.4JNqV7 2>&1'
Info: No AVC messages found.
/bin/grep 'avc: ' /mnt/testarea/dmesg.log | /bin/grep --invert-match TESTOUT.log
No AVC messages found in dmesg
Running '/usr/sbin/sestatus'
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      31
Running 'rpm -q selinux-policy || true'
selinux-policy-3.13.1-207.el7.noarch


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-207.el7.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Didn't have this issue with RHEL-7.5. Didn't expect to see it on RHEL-7.6.

Additional info:

Comment 7 errata-xmlrpc 2018-10-30 10:07:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.