Bug 160856 - crash when reloading any page
Summary: crash when reloading any page
Keywords:
Status: CLOSED DUPLICATE of bug 160330
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 159797 160330
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 20:41 UTC by Robin Humble
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 19:43:45 UTC
Type: ---


Attachments (Terms of Use)
stack trace from bug-buddy (10.35 KB, text/plain)
2005-07-11 17:54 UTC, Robin Humble
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 309875 0 None None None Never
Mozilla Foundation 293307 0 None None None Never

Description Robin Humble 2005-06-17 20:41:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I rebuilt the fc3 galeon rpm for fc4.
it can display pages fine, but any attempt to reload a page via the reload button crashes the browser immediately.
i386 version seems ok. on x86_64 it crashes every time.

Version-Release number of selected component (if applicable):
galeon-1.3.21-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild galeon-1.3.21-2.fc3.src.rpm
2. rpm -Uvh galeon-1.3.21-2.fc3.x86_64.rpm
3. galeon
4. press the reload button
  

Actual Results:  crash. I couldn't see a core file anywhere.

Expected Results:  doesn't crash

Additional info:

can I trace it with gdb or strace somehow?

Comment 1 Alex Lancaster 2005-06-24 08:25:50 UTC
This is probably an upstream error and needs to reported to the galeon
maintainers at http://bugzilla.gnome.org.  I have built my own fc4 rpm
on i386 and succesfully built and installed galeon.

Also note my rebuild request (bug # 159797) for galeon.

Comment 2 Burkhard 2005-07-08 02:39:49 UTC
This issue is new, since I upgraded to FC4.

On FC3 I used to compile galeon from tarball - no problem.

Yesterday I upgraded to FC4 and now I face this problem as described above.

Since then I tried the 1.3.20 and 1.3.21 tarballs, the FC3-Extras-RPM, used
gcc32 as well as gcc4, but it's always the same.


Comment 3 Dams 2005-07-08 05:23:25 UTC
I can reproduce it here.

Comment 4 Robin Humble 2005-07-11 17:54:25 UTC
Created attachment 116611 [details]
stack trace from bug-buddy

This problem still exists in the latest galeon build - 1.3.21-8.x86_64

I've added this log to the bug report over at gnome.
  http://bugzilla.gnome.org/show_bug.cgi?id=308350

Comment 5 Dams 2005-07-11 18:40:36 UTC
I've filled a bug report here : http://bugzilla.gnome.org/show_bug.cgi?id=309875
They seem to say it's a problem in mozilla.

Comment 6 Dams 2005-07-11 19:43:45 UTC

*** This bug has been marked as a duplicate of 160330 ***


Note You need to log in before you can comment on or make changes to this bug.