Bug 160859 - losetup does not work with selinux-policy-targeted-1.23.16-6
losetup does not work with selinux-policy-targeted-1.23.16-6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-17 16:52 EDT by Stefan Hoelldampf
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 06:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Hoelldampf 2005-06-17 16:52:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
after the FC3->FC4 upgrade losetup does not work anymore:

# losetup /dev/loop0 test.img
audit(1118949662.609:50): avc:  denied  { search } for  pid=24032
comm="losetup" name=root dev=dm-0 ino=1775393
scontext=root:system_r:fsadm_t tcontext=root:object_r:user_home_dir_t
tclass=dir
loop: can't open device test.img: Permission denied

# ls -alZ test.img
-rw-r--r--  root     root     root:object_r:user_home_t        test.img



Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.16-6

How reproducible:
Always

Steps to Reproduce:
1. see above


Additional info:
Comment 1 Nils Toedtmann 2005-06-20 09:02:46 EDT
This bug is a duplicate of #160755 (but has a better summary!)

Unfortunately i do not know how to mark this in the bugzila db :-(
Comment 2 Stefan Hoelldampf 2005-06-21 06:41:40 EDT
Fixed in selinux-policy-targeted-1.23.18-12

Note You need to log in before you can comment on or make changes to this bug.