Bug 1608597 - Content Host Applicable Package List page can DOS Satellite
Summary: Content Host Applicable Package List page can DOS Satellite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: jcallaha
URL:
Whiteboard:
: 1614354 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-25 22:31 UTC by Mike McCune
Modified: 2019-09-25 21:21 UTC (History)
3 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.5.78-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1610424 (view as bug list)
Environment:
Last Closed: 2018-08-22 20:07:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed Patch 001 (1.78 KB, patch)
2018-07-25 22:34 UTC, Mike McCune
no flags Details | Diff
tfm-rubygem-katello-3.4.5.74-2.RHBZ1608597.tar (4.68 MB, application/x-tar)
2018-07-26 21:27 UTC, Mike McCune
no flags Details
verification video (540.79 KB, application/octet-stream)
2018-08-03 18:30 UTC, jcallaha
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 24389 0 Normal Closed Content Host Applicable Package List page can DOS Foreman server and Postgres 2020-06-09 13:26:09 UTC
Red Hat Product Errata RHBA-2018:2550 0 None None None 2018-08-22 20:07:18 UTC

Description Mike McCune 2018-07-25 22:31:08 UTC
1) Take large Satellite installation with 20,000 content hosts
2) Navigate to Content Host -> Pick a host with applicable Errata
3) Click Packages -> Applicable Packages
4) On large installations this page will never return (query takes 4h+ to complete).

During execution of said query, Postgres will consume 20-40GB of disk swapping out the query results, consuming way more resources than it should and slowing overall operations of the Satellite.

Comment 1 Mike McCune 2018-07-25 22:34:04 UTC
Created attachment 1470560 [details]
Proposed Patch 001

Comment 3 pm-sat@redhat.com 2018-07-26 00:09:02 UTC
Upstream bug assigned to mmccune@redhat.com

Comment 4 pm-sat@redhat.com 2018-07-26 00:09:04 UTC
Upstream bug assigned to mmccune@redhat.com

Comment 5 Mike McCune 2018-07-26 18:58:14 UTC
You can test this even on a Satellite with ~1000-2000 Hosts with applicable errata. The page will take 30-40 seconds to load before this patch.

With this update it will render quickly in under a second.

Comment 6 pm-sat@redhat.com 2018-07-26 20:08:54 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/24389 has been resolved.

Comment 7 Mike McCune 2018-07-26 21:27:15 UTC
*** Satellite 6.3.2 Hotfix Instructions ***

1) download tfm-rubygem-katello-3.4.5.74-2.RHBZ1608597.tar from bug to Satellite server

2) untar archive

3) rpm -Uvh *.rpm

4) katello-service restart

5) resume operations

Comment 8 Mike McCune 2018-07-26 21:27:50 UTC
Created attachment 1470886 [details]
tfm-rubygem-katello-3.4.5.74-2.RHBZ1608597.tar

Comment 12 jcallaha 2018-08-03 18:30:08 UTC
Created attachment 1473222 [details]
verification video

Verified in Satellite 6.3.3 Snap 2.

I setup over 4k content hosts, each with 376 applicable packages.

Following the steps outlined in the initial report, I saw that that load times, of the applicable packages page, only took a couple of seconds. This is significantly lower than the 30s load times expected with only 1000 content hosts.

See attached webm for verification

Comment 13 jcallaha 2018-08-14 17:43:20 UTC
*** Bug 1614354 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2018-08-22 20:07:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2550


Note You need to log in before you can comment on or make changes to this bug.