Bug 1608887 - Not able to see any options to edit on glusterd2 github issues
Summary: Not able to see any options to edit on glusterd2 github issues
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-26 12:47 UTC by Pranith Kumar K
Modified: 2018-07-26 14:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-26 13:27:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2018-07-26 12:47:29 UTC
Description of problem:

I am not sure if this is the right component to raise infra issues on glusterd2, but here it goes. I am not able to add labels on glusterd2 github project. I don't see any option to do that so I am wondering if there is any issue with permissions. So raising an issue to find out what could be the problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Prashanth Pai 2018-07-26 13:27:32 UTC
Only maintainers can.

Unfortunately, the option that allows permission to set/edit labels is a very broad one. Turning that on also gives you write permissions (git push directly etc). There'e no granularity provided by GitHub there.

Comment 2 Pranith Kumar K 2018-07-26 13:39:41 UTC
Hmm... I wonder how to track the dependencies on glusterd2 for monitoring in github. Does anyone have any inputs?

Comment 3 Prashanth Pai 2018-07-26 14:00:42 UTC
(In reply to Pranith Kumar K from comment #2)
> Hmm... I wonder how to track the dependencies on glusterd2 for monitoring in
> github. Does anyone have any inputs?

You can simply ask the maintainers to set/edit/add labels for glusterd2 :)

Tracking issues across multiple repos of the same GitHub organisation seems possible. Check this common issues dashboard:

https://github.com/issues?utf8=%E2%9C%93&q=is%3Aopen+is%3Aissue+archived%3Afalse+user%3Agluster+ 

Filtering by label seems to be not enabled in the UI as a button. However, entering the label manually seem to work:

Example label 'bug':

https://github.com/issues?page=1&q=is%3Aopen+is%3Aissue+archived%3Afalse+user%3Agluster+label%3Abug&utf8=%E2%9C%93


Note You need to log in before you can comment on or make changes to this bug.