Bug 160918 - installer gets "could not set controlling tty" and hangs after "running /sbin/loader"
installer gets "could not set controlling tty" and hangs after "running /sbin...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 160919 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-18 11:51 EDT by Michael D Miller
Modified: 2015-01-04 17:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 17:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael D Miller 2005-06-18 11:51:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Installer outputs "could not set controlling tty" and hangs after "running /sbin/loader". I have tried graphic and text mode and get the same result. FC2 and FC3 don't have this problem. I have retried them both.
Thanks,
Mike

Version-Release number of selected component (if applicable):
10.2.1.5

How reproducible:
Always

Steps to Reproduce:
1.Start build from cd1 or rescue cd.
2.
3.
  

Actual Results:  The system will hang until I <CLT ALT DEL>. It them dismounts the filesystems and reboots. I can't install FC4:-(

Expected Results:  The install process should have started text mode or graphic mode depending on input.

Additional info:

The graphics card is a Gforce FX 5700LE 256mg  AGP by BFG Technologies. MB is MSI MS6570, processor is AMD Athlon XP3200.
Comment 1 Chris Lumens 2005-06-18 11:57:07 EDT
*** Bug 160919 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2005-06-20 13:59:05 EDT
Does it work if you boot with 'linux nofb'?
Comment 3 Todd Cary 2005-06-27 11:54:11 EDT
I have tried all of the options and they all fail.
Comment 4 Paul Tinsley 2005-07-06 22:12:06 EDT
I am also having this problem with fedora core 4, but I am using the dvd iso of
the 64bit version.  I have tried the nofb listed above and get the same result
just sitting at "running /sbin/loader".

The only things on the screen that look "bad" are:
"powernow-k8: BIOS error - no PSB or ACPI _PSS objects"
and
"could not set new controlling tty"

all of the rest of the console messages look normal.

My hardware is an AMD 64 3500+ on an MSI Neo2 motherboard.
Comment 5 Paul Tinsley 2005-07-06 22:36:54 EDT
Little more info incase it helps, the normal x86 FC4 dvd iso gets past the
/sbin/loader hang.  Where the 64bit dvd doesn't...
Comment 6 Fedy2 2005-07-14 17:13:54 EDT
same problem
with DVD iso FC 4 64
in
cpu Athlon 64 3400+
nvidia geForce FX Go5700
mobo NVIDIA nForce3 Go150

bye
Comment 7 Mark Pace 2005-07-22 08:06:51 EDT
I get the exact same results on an IBM xSeries 360.
I've tried several combinations of parameters
linux nofb
linux mediacheck
linux text
linux askmethod

All do exactly the same thing.
Comment 8 Mark Pace 2005-07-22 10:50:49 EDT
mpace58@comcast.net
Comment 9 Michael D Miller 2005-07-22 17:45:56 EDT
I have a usb keyboard and the bios wasn't set for it. I set usb keyboard "on" in
the bios and no more problem. Things went aloog great for a couple of weeks and
I started getting hangs in startup just after the initialization of the disks,
audio and something I don't recall right now but I noticed the transformer for
my usb attached ZIP drive had come loose from the electrical socket. Pluged the
electrical back in and once again no problems. USB seems to be a pain in the
a--. If you are having problem get into the bios and turn the usb ports off and
reboot. If the system comes up figgure which usb device is the problem. (Don't
forget to turn usb back on in the bios)
Hope this helps.
Mike
Comment 10 Mark Pace 2005-07-25 09:07:24 EDT
Thanks for the input, Michael.  I had a dongle in the USB port from a previous
application.  I removed the dongle, rebooted, and I am now past the hang
condition I was experiencing.
Comment 11 Eric Schultz 2005-08-29 19:08:00 EDT
I am having the same problem, there is no "dongle" attached to my computer however.

I am running an IBM Bladecenter HS20 Type 8678 Blade Specs are:
Processor: Intel Xeon 2.4G
Mem: 512 Meg
Nic: Dual Broadcomm NetXtream 1k/100/10
Video: ATI Mach 64
Keyboard,Mouse,CD,Floppy are considered USB

I am doing a network insall (i.e. booting through PXE and have the sources on
NFS.) FC3 works just fine on this blade.

As above it boots, I get "could not set new controlling tty", and it hangs at
/sbin/loader

I have tried it with nofb vnc askmethod and text. All do the same. I have even
changed the media tray to another blade (effectivly diconnecting the cdrom and
floppy)... still the same problem. I'd love to use fc4 (because xen would be
sweet on this system.)

Any assistance would be greatly appreciated.

Comment 12 Feng Qi 2011-08-26 04:29:02 EDT
I got my problem fixed by unplugging the power cable of the cdrom and then it works. It seems the bad server part might cause this kind of problem.

Environments:
RedHat 6.4 - 64bit.
kickstart
DL320G5

Note You need to log in before you can comment on or make changes to this bug.