Bug 1609215 - [admin] User without project gets unfriendly message on Event page
Summary: [admin] User without project gets unfriendly message on Event page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-27 09:49 UTC by XiaochuanWang
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On the events page, we did not have any logic to handle the case where a user had no projects available. Consequence: The user would receive an error message when visiting the events page if they did not have any projects available. Fix: Added logic to the events page to handle the case where there are no projects available to the current user. Result: When a user visits the events page while no projects are available, a "getting started" message about how to create their first project will be displayed, and the events list will show an empty state instead of an error message.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description XiaochuanWang 2018-07-27 09:49:33 UTC
Description of problem:
Make sure logged-in user has no project, browse to Event page, the message is not user friendly

Version-Release number of selected component (if applicable):
openshift v3.11.0-0.9.0
kubernetes v1.11.0+d4cacc0
registry.reg-aws.openshift.com:443/openshift3/ose-console                   v3.11               e03103f86278        3 days ago          273 MB

How reproducible:
Always

Steps to Reproduce:
1. User without project login
2. Browse to Event project and check

Actual results:
2. The user got below message
"""
Error connecting to event stream: WebSocket closed uncleanly.
Error Loading Events
An error occurred during event retrieval. Attempting to reconnect...
"""

Expected results:
2. Page shows friendly message such as "No Events Found"

Additional info:

Comment 1 Jon Jackson 2018-07-27 19:29:33 UTC
https://github.com/openshift/console/pull/327

Comment 2 Jon Jackson 2018-12-18 19:24:16 UTC
https://github.com/openshift/console/pull/327

Comment 4 XiaochuanWang 2019-01-16 07:08:39 UTC
Verified on $ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-010905   True        False         11m       Cluster version is 4.0.0-0.nightly-2019-01-15-010905

"version": "v4.0.0"
"release": "0.139.0.0",
"io.openshift.source-repo-commit": "a62eaa43f2aab9a817a3fb66e1c8b88d5ef100da",

Comment 7 errata-xmlrpc 2019-06-04 10:40:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.