Bug 160924 - permission denied for cd/dvd device
permission denied for cd/dvd device
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Depends On:
  Show dependency treegraph
Reported: 2005-06-18 14:41 EDT by Gérard Milmeister
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-27 08:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2005-06-18 14:41:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
hdparm (root)  works fine for HD devices, but on /dev/hdd which
is a DVD device, it only says:
/dev/hdd: Permission denied

I tried hdparm-6.1 which works fine as before.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. As root: /sbin/hdparm /dev/cdrom
2. Returns: /dev/cdrom: Permission denied


Additional info:
Comment 1 Karsten Hopp 2005-06-23 05:26:10 EDT
what are the permissions of /dev/cdrom or if it is a link the device file it
points at ?
Comment 2 Gérard Milmeister 2005-06-23 13:29:08 EDT
Now it works again. After rebooting I couldn't reproduce the problem...
But maybe there is a bug deeply hidden that only shows under certain unlikely
Comment 3 Karsten Hopp 2005-06-27 08:21:19 EDT
closing based on last comment. This looks more like a udev problem anyway. (udev
creates the device files in /dev) 

Note You need to log in before you can comment on or make changes to this bug.