Bug 1609492 - python-backcall: requires python(abi) without version (%?python_enable_dependency_generator)
Summary: python-backcall: requires python(abi) without version (%?python_enable_depend...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rpm-generators
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Orsava
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3 PYTHON3-PYTHON2
TreeView+ depends on / blocked
 
Reported: 2018-07-28 15:04 UTC by Iryna Shcherbina
Modified: 2018-07-28 23:44 UTC (History)
8 users (show)

Fixed In Version: python-rpm-generators-5-4.fc29, python-backcall-0.1.0-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-28 20:55:52 UTC


Attachments (Terms of Use)

Description Iryna Shcherbina 2018-07-28 15:04:24 UTC
The python3-backcall RPM requires both Python 2 and Python 3:

$ dnf repoquery --repo=rawhide --requires python3-backcall
python(abi)
python(abi) = 3.7

Except in very special circumstances, there is no need for one package
to drag in both Python stacks. Usually, this is a packaging error.

Please split your package, or remove the stray dependencies.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 28 as well.


If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing this issue!

Comment 1 Miro Hrončok 2018-07-28 19:55:17 UTC
I was fighting the "python(abi)" requires even with my 3.6 repoqueries. I have no idea why it is there, but if I remove "%?python_enable_dependency_generator", it's gone.

This only happens on rawhide.

Comment 2 Miro Hrončok 2018-07-28 20:14:04 UTC
I think I found a fix, will send a PR.


Note You need to log in before you can comment on or make changes to this bug.