Bug 160950 - Chars on console lost when switching out of X11
Chars on console lost when switching out of X11
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 03:23 EDT by Michael Forrest
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-25 06:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Forrest 2005-06-19 03:23:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When computer boots, the 80x25 text mode console functions correctly (i.e.
all characters visible, no blue border).

I am presently using initmode 3.  When I use 'startx', I get a
functioning X desktop.

When I either Log Out of the X (GNOME) session, or use 'Ctrl-Alt-Fn',
I do get back to a textmode console, HOWEVER, there is now a blue line
along the left hand side that is partially obscuring all the characters
in column 0.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31 kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1.Computer boots into initmode 3 (no missing chars)
2.Use startx, then either log out or switch back to text mode console
3.
  

Actual Results:  Blue Line appears on left hand side and across the bottom of the screen.
The blue line is continuous and is obscuring some of the pizels (not all)
of the characters in column 0 on the left hand side of the screen.
The chracters are obscured enough to make them unrecognisable.
Also, some white pixels are switching on in column 79 (right hand side).

Expected Results:  Text mode console fully restored after X server has had control of the screen.

Additional info:

I have a 19 inch LCD monitor (CMV 922D).

This appears to be a regression: it did NOT ovvur with a fully updated
(xorg 6.8.2, kernel 2.6.11-1.27) Fedorca Core 3 on the same computer using
the same monitor.
Comment 1 Mike A. Harris 2005-06-22 17:35:55 EDT
Please review bug number 161242 everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.
Comment 2 Michael Forrest 2005-06-25 06:57:48 EDT
Tried shutting X down (which gave the blue borders problem, as expected).

Replaced libvgahw.a with same from FC3, started X )with startx), then used
Ctrl-Alt-Fn to switch back to tty1.

Blue border was still there, still hiding the characters in column 0 as before.

BUT, then rebooted completely, tried same test, and no more blue border on the
80x25 textmode screen! So I think we've narrowed down the problem to that
particular module. Strange how it wasn't fixed with a new X server with the FC3
moduoe in place - could it have kept some bad code in the kernel, which was only
removed with a reboot? It will be mighty strange if this turns out to be a gcc
4.0 bug!

Anyway, this issue has been worked around for me. My deepest thanks to Mike
Harris for taking the time to attach that message to the many reports of
corruption. Made it easy to workaround.

Marking this as a duplicate.


*** This bug has been marked as a duplicate of 161242 ***
Comment 3 Michael Forrest 2005-06-25 07:03:40 EDT
Oh, forgot to confirm that my display is an i810 Intel chipset on a Gateway
E1600 Motherboard (Pentium III - 800 Mhz). Hope we can find the real cause!

Note You need to log in before you can comment on or make changes to this bug.