Bug 1609503 - gridData.tests.test_dx.test_write_dx_ValueError fails on armv7hl
Summary: gridData.tests.test_dx.test_write_dx_ValueError fails on armv7hl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-GridDataFormats
Version: 29
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2018-07-28 17:41 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2019-09-29 02:22 UTC (History)
1 user (show)

Fixed In Version: python-GridDataFormats-0.5.0-1.fc31 python-GridDataFormats-0.5.0-1.fc30 python-GridDataFormats-0.5.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-29 00:01:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github MDAnalysis GridDataFormats issues 51 None None None Never

Description Dominik 'Rathann' Mierzejewski 2018-07-28 17:41:27 UTC
Description of problem:
When running 0.4.0 tests (with 605a20f applied) on Fedora rawhide on armv7hl (ARM 32-bit), gridData.tests.test_dx.test_write_dx_ValueError test fails:

Version-Release number of selected component (if applicable):
python-GridDataFormats-0.4.0-3.fc29

How reproducible:
Always

Steps to Reproduce:
1. cd GridDataFormats-0.4.0
2. /usr/bin/python2 setup.py nosetests

Actual results:
running nosetests
running egg_info
writing requirements to GridDataFormats.egg-info/requires.txt
writing GridDataFormats.egg-info/PKG-INFO
writing top-level names to GridDataFormats.egg-info/top_level.txt
writing dependency_links to GridDataFormats.egg-info/dependency_links.txt
reading manifest file 'GridDataFormats.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching 'README'
writing manifest file 'GridDataFormats.egg-info/SOURCES.txt'
.............F............S..
======================================================================
FAIL: gridData.tests.test_dx.test_write_dx_ValueError
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/usr/lib/python2.7/site-packages/nose/tools/nontrivial.py", line 60, in newfunc
    func(*arg, **kw)
  File "/builddir/build/BUILD/GridDataFormats-0.4.0/gridData/tests/test_dx.py", line 89, in test_write_dx_ValueError
    return _test_write_dx(nptype=nptype, dxtype=dxtype)
  File "/builddir/build/BUILD/GridDataFormats-0.4.0/gridData/tests/test_dx.py", line 48, in _test_write_dx
    assert_equal(out_dxtype, dxtype)
  File "/usr/lib/python2.7/site-packages/numpy/testing/nose_tools/utils.py", line 411, in assert_equal
    raise AssertionError(msg)
AssertionError: 
Items are not equal:
 ACTUAL: 'double'
 DESIRED: 'unknown'
----------------------------------------------------------------------
Ran 29 tests in 1.106s
FAILED (SKIP=1, failures=1)

Expected results:
Test passes.

Additional info:
It looks like np.longdouble and np.double are different on x86 32bit:

$ arch
i686
$ rpm -q python2-numpy
python2-numpy-1.14.5-3.fc29.i686
$ python2
Python 2.7.15 (default, Jul 15 2018, 06:03:07) 
[GCC 8.1.1 20180626 (Red Hat 8.1.1-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy as np
>>> np.longdouble
<type 'numpy.float96'>
>>> np.double
<type 'numpy.float64'>
>>> 

but they're the same on ARM 32bit:

$ arch
armv7l
$ rpm -q python2-numpy
python2-numpy-1.14.5-3.fc29.armv7hl
$ python2
Python 2.7.15 (default, Jul 15 2018, 05:48:59) 
[GCC 8.1.1 20180626 (Red Hat 8.1.1-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy as np
>>> np.longdouble
<type 'numpy.float64'>
>>> np.double    
<type 'numpy.float64'>
>>> 

I'm not sure if this means it's a bug in numpy or the test is making some unwarranted assumption.

Comment 1 Jan Kurik 2018-08-14 08:40:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Fedora Update System 2019-09-20 20:33:20 UTC
FEDORA-2019-48f5cd3794 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-48f5cd3794

Comment 3 Fedora Update System 2019-09-20 20:33:25 UTC
FEDORA-2019-4e05aaba50 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e05aaba50

Comment 4 Fedora Update System 2019-09-21 01:08:41 UTC
python-GridDataFormats-0.5.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-48f5cd3794

Comment 5 Fedora Update System 2019-09-21 02:01:06 UTC
python-GridDataFormats-0.5.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e05aaba50

Comment 6 Fedora Update System 2019-09-21 03:04:35 UTC
python-GridDataFormats-0.5.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c3ff3da4e0

Comment 7 Fedora Update System 2019-09-29 00:01:01 UTC
python-GridDataFormats-0.5.0-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-09-29 02:01:51 UTC
python-GridDataFormats-0.5.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-09-29 02:22:39 UTC
python-GridDataFormats-0.5.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.